Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
NAT Problem
#1
Frog 
Hi,
In vuze, torrents are always Yellow. Also NAT indicator stays Red. But Dowloads are running @ full bandwidth.
I set up UPnP/NAT-PMP in Linksys E900 router with Tomato 1.28 by Shibby. (Attachment: UPnp.PNG)
Also in NAT/Firewall test in Vuze, the test for UDP listen port runs OK.
"Testing port UDP 49668 ... 
    Sending outbound packet and waiting for reply probe (timeout=5000)
    Sending completion event
OK !
"
But the test for TCP listen port is giving error:
"Testing port TCP 49668 ... 
NAT Error - Connection timed out (106.51.129.20:49668).
"
Also a separate firewall rule is created in Symantec Endpoint. (Attachemnt: Firewall.png)

Connection: Advanced Network Settings:
Bind to local ip address or interface: <Blank>
The following interfaces are available:
"net6    (Intel® Dual Band Wireless-N 7260-Virtual WiFi Filter Driver-0000)
    lo    (Software Loopback Interface 1)
        lo[0]    127.0.0.1
        lo[1]    0:0:0:0:0:0:0:1
    eth3    (Realtek PCIe GBE Family Controller-WFP Native MAC Layer LightWeight Filter-0000)
    net5    (Intel® Dual Band Wireless-N 7260-WFP Native MAC Layer LightWeight Filter-0000)
    eth4    (Realtek PCIe GBE Family Controller-QoS Packet Scheduler-0000)
    net8    (Intel® Dual Band Wireless-N 7260-QoS Packet Scheduler-0000)
    eth1    (Realtek PCIe GBE Family Controller)
        eth1[0]    fe80:0:0:0:6ced:b8b6:55cd:5748%3
    net7    (Intel® Dual Band Wireless-N 7260-Native WiFi Filter Driver-0000)
    eth2    (Bluetooth Device (Personal Area Network))
        eth2[0]    fe80:0:0:0:c9b1:7ff9:4ee8:30f4%6
    net13    (Microsoft Wi-Fi Direct Virtual Adapter-QoS Packet Scheduler-0000)
    net12    (Microsoft Wi-Fi Direct Virtual Adapter-Native WiFi Filter Driver-0000)
    net9    (Intel® Dual Band Wireless-N 7260-WFP 802.3 MAC Layer LightWeight Filter-0000)
    net11    (Microsoft Wi-Fi Direct Virtual Adapter-WFP Native MAC Layer LightWeight Filter-0000)
    eth5    (Realtek PCIe GBE Family Controller-WFP 802.3 MAC Layer LightWeight Filter-0000)
    net10    (Intel® Dual Band Wireless-N 7260-Symantec Endpoint Protection Firewall-0000)
    eth6    (Realtek PCIe GBE Family Controller-Symantec Endpoint Protection Firewall-0000)
    net0    (Microsoft ISATAP Adapter)
        net0[0]    fe80:0:0:0:0:5efe:c0a8:12a%4
    net2    (Bluetooth Device (RFCOMM Protocol TDI))
    eth0    (Microsoft Kernel Debug Network Adapter)
    net1    (Teredo Tunneling Pseudo-Interface)
        net1[0]    2001:0:9d38:90d7:303c:40a:3f57:fed5
        net1[1]    fe80:0:0:0:303c:40a:3f57:fed5%5
    net4    (Microsoft Wi-Fi Direct Virtual Adapter)
        net4[0]    fe80:0:0:0:e8f6:836b:4a66:3b13%9
    net3    (Intel® Dual Band Wireless-N 7260)
        net3[0]    192.168.1.42
        net3[1]    fe80:0:0:0:6d81:3ee7:a019:14f3%8
    net15    (Microsoft Wi-Fi Direct Virtual Adapter-Symantec Endpoint Protection Firewall-0000)
    net14    (Microsoft Wi-Fi Direct Virtual Adapter-WFP 802.3 MAC Layer LightWeight Filter-0000)
    net17    (Teredo Tunneling Pseudo-Interface-Symantec Endpoint Protection Firewall-0000)
    net16    (Microsoft ISATAP Adapter-Symantec Endpoint Protection Firewall-0000)

    "

Vuze: System:
Java 1.7.0_67
Oracle Corporation
SWT v4233, win32
Windows 8 v6.2, amd64
V5.4.0.0/4 az2

Please help fix this NAT issue. If any information is left out, please ask.
Thanks
 

 


Attached Files Thumbnail(s)
       
Reply
#2
That is very weird....

Did you enable both UPnP and NAT-PMP in Vuze (by default NAT-PMP is disabled under Tools->Options->UPnP->NAT-PMP)

If so there is a vague possibility that having both active confuses things, disable NAT-PMP in Vuze (+restart) and see if that helps.

If your downloads are running well then its not the end of the world if you can't figure it out (although I know it's annoying)
Reply
#3
Yes both of them was enabled.
NAT-PMP is disabled now. Restarted Vuze.
Still NAT indicator is Red (Firewalled)

In network Status:
"Test starting
Default public address is 106.51.129.20
1 NAT device found
    UPnP router: address=192.168.1.1:29583, public address=10.251.85.133
No SOCKS proxy found
No HTTP proxy found
No explicit bind address set
Testing HTTP outbound
    Test successful
Testing TCP outbound
    Test successful
Testing UDP outbound
    Test successful
Testing TCP port 49668 inbound
    Test failed: NAT test failed: Connection timed out (106.51.129.20:49668)
    Check your port forwarding for TCP 49668
Testing UDP port 49668 inbound
    Sending outbound packet and waiting for reply probe (timeout=5000)
    Sending completion event
    Test successful
1 public/external addresses found
    106.51.129.20
    AS details: as=24309,asn=CABLELITE-AS-AP Atria Convergence Technologies Pvt. Ltd. Broadband Internet Service Provider INDIA,IN, bgp_prefx=106.51.128.0/22[/106.51.128.0-/106.51.131.255]
Vuze Services test
    Vuze Website - http://www.vuze.com
        Certificate: CN=*.vuze.com, OU=Domain Control Validated - RapidSSL®, OU=See http://www.rapidssl.com/resources/cps ©13, OU=GT10270993, SERIALNUMBER=6iRebnvENcZAngMRRe2EIbG-U9aO6U7U
        Connection result: 200/OK
    Client Website - client.vuze.com
        Certificate: CN=*.vuze.com, OU=Domain Control Validated - RapidSSL®, OU=See http://www.rapidssl.com/resources/cps ©13, OU=GT10270993, SERIALNUMBER=6iRebnvENcZAngMRRe2EIbG-U9aO6U7U
        Connection result: 200/OK
    Version Server - version.vuze.com
        Connection result: 200/OK
    Pairing Server - pair.vuze.com
        Certificate: CN=*.vuze.com, OU=Domain Control Validated - RapidSSL®, OU=See http://www.rapidssl.com/resources/cps ©13, OU=GT10270993, SERIALNUMBER=6iRebnvENcZAngMRRe2EIbG-U9aO6U7U
        Connection result: 200/OK
    License Server - license.vuze.com
        Certificate: CN=*.vuze.com, OU=Domain Control Validated - RapidSSL®, OU=See http://www.rapidssl.com/resources/cps ©13, OU=GT10270993, SERIALNUMBER=6iRebnvENcZAngMRRe2EIbG-U9aO6U7U
        Connection result: 200/OK
    Plugins Website - plugins.vuze.com
        Certificate: CN=*.vuze.com, OU=Domain Control Validated - RapidSSL®, OU=See http://www.rapidssl.com/resources/cps ©13, OU=GT10270993, SERIALNUMBER=6iRebnvENcZAngMRRe2EIbG-U9aO6U7U
        Connection result: 200/OK
Indirect Connect test
    Connecting to https://www.vuze.com
    Failed: Connect timed out
    Check the logs for the 'Tor Helper Plugin' (Tools->Plugins->Log Views)

Distributed protocol test
  Incoming routing established for 4F624329B084AE5F905D50D45EE5766B70D155C8
  Searching 128 contacts for 8 test targets
  Making outbound connection to /86.75.33.85:52338
  Making outbound connection to /173.179.72.168:12735
  Making outbound connection to /121.45.216.35:54545
  Making outbound connection to /89.240.24.52:13602
  Making outbound connection to /99.226.208.197:53812
  Making outbound connection to /84.221.137.164:57967
  Making outbound connection to /50.179.19.4:51722
  Making outbound connection to /66.0.163.242:6881
  Searching complete, 8 targets found
    Status: sessions=8, out_attempts=8, out_connect=8, in_connect=0
  Destroying tester
  Results
Test complete
    Outbound,Leecher,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Seed,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Leecher,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Seed,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Leecher,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Seed,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Leecher,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Seed,connected, hand sent, hand recv, bitf sent, bitf recv
    No incoming connections received, likely NAT problems
  Incoming routing destroyed for 4F624329B084AE5F905D50D45EE5766B70D155C8"
Reply
#4
It's SOLVED!!!!!!!!!!!!

Option > Mode > Reset

I used to import previous vuze settings, ongoing downloads, older download history by copying from older installation the "C:\Users\XX\AppData\Roaming\Azureus" folder. And recently I shifted to a new place with different network setup, so older vuze configuration was conflicting.
Reply
#5
Again NAT Problem/Firewalled
:(
Reply
#6
Does a specific torrent cause NAT indiactor to go Red?
Reply
#7
Thumbs Up 
(10-17-2014, 01:01 PM)'td7' Wrote: It's SOLVED!!!!!!!!!!!!

Option > Mode > Reset

I used to import previous vuze settings, ongoing downloads, older download history by copying from older installation the "C:\Users\XX\AppData\Roaming\Azureus" folder. And recently I shifted to a new place with different network setup, so older vuze configuration was conflicting.

 

This worked for me!
Reply
#8
I can't get this damn NAT error fixed.  "Option > Mode > Reset" did not work

My network test is as such:
--------------------------------------------------------------------------------------------------------
Test starting
Default public address is 101.167.174.50
Bindable addresses: 127.0.0.1, 192.168.1.90
1 NAT device found
    RT-AC68U: address=192.168.1.1:34894, public address=101.167.174.50
No SOCKS proxy found
No HTTP proxy found
No explicit bind address set
Testing HTTP outbound
    Test successful
Testing TCP outbound
    Test successful
Testing UDP outbound
    Test successful
Testing TCP port 6881 inbound
    Test failed: NAT test failed: Connection timed out (101.167.174.50:6881)
    Check your port forwarding for TCP 6881
Testing UDP port 6881 inbound
    Sending outbound packet and waiting for reply probe (timeout=5000)
    Sending outbound packet and waiting for reply probe (timeout=10000)
    Sending outbound packet and waiting for reply probe (timeout=15000)
    Sending completion event
    Test failed: Inbound test failed
    Check your port forwarding for UDP 6881
1 public/external addresses found
    101.167.174.50
    AS details: as=1221,asn=ASN-TELSTRA Telstra Pty Ltd, AU, bgp_prefx=101.160.0.0/11[/101.160.0.0-/101.191.255.255]
Vuze Services test
    Vuze Website - http://www.vuze.com
        Certificate: CN=*.vuze.com, OU=Domain Control Validated - RapidSSL®, OU=See http://www.rapidssl.com/resources/cps ©15, OU=GT10270993
        Connection result: 200/OK
    Client Website - client.vuze.com
        Certificate: CN=*.vuze.com, OU=Domain Control Validated - RapidSSL®, OU=See http://www.rapidssl.com/resources/cps ©15, OU=GT10270993
        Connection result: 200/OK
    Version Server - version.vuze.com
        Connection result: 200/OK
    Pairing Server - pair.vuze.com
        Certificate: CN=*.vuze.com, OU=Domain Control Validated - RapidSSL®, OU=See http://www.rapidssl.com/resources/cps ©15, OU=GT10270993
        Connection result: 200/OK
    License Server - license.vuze.com
        Certificate: CN=*.vuze.com, OU=Domain Control Validated - RapidSSL®, OU=See http://www.rapidssl.com/resources/cps ©15, OU=GT10270993
        Connection result: 200/OK
    Plugins Website - plugins.vuze.com
        Certificate: CN=*.vuze.com, OU=Domain Control Validated - RapidSSL®, OU=See http://www.rapidssl.com/resources/cps ©15, OU=GT10270993
        Connection result: 200/OK
Indirect Connect test
    Connecting to https://www.vuze.com
    Certificate: CN=*.vuze.com, OU=Domain Control Validated - RapidSSL®, OU=See http://www.rapidssl.com/resources/cps ©15, OU=GT10270993
    Connection result: 200/OK
Distributed protocol test
  Incoming routing established for 6B45A5DD5213684BBA0424F8C9212E017CB0C264
  Searching 118 contacts for 8 test targets
  Making outbound connection to /222.155.60.28:42914
  Making outbound connection to /60.71.141.1:38496
  Making outbound connection to /95.144.187.173:39638
  Making outbound connection to /94.11.194.6:32544
  Making outbound connection to /146.90.124.56:40251
  Making outbound connection to /90.220.235.28:50616
  Making outbound connection to /174.104.183.250:63054
  Making outbound connection to /86.186.123.235:16230
  Making outbound connection to /46.7.34.223:62020
  (LS 4) Outbound connection fail: end of stream on socket read
  Making outbound connection to /93.29.43.14:19199
  Searching complete, 10 targets found
  (LS 6) Outbound connection fail: Connection attempt to 90.220.235.28:50616 aborted: timed out after 15sec
    Status: sessions=8, out_attempts=10, out_connect=9, in_connect=0
  Destroying tester
  Results
Test complete
    Outbound,Leecher,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Seed,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Leecher,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Seed,connected, hand sent, hand !recv, bitf !sent, bitf !recv
    Outbound,Leecher,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Seed,not connected
    Outbound,Leecher,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Seed,connected, hand sent, hand recv, bitf sent, bitf recv
    Outbound,Leecher,connected, hand sent, hand !recv, bitf !sent, bitf !recv
    Outbound,Leecher,connected, hand sent, hand !recv, bitf !sent, bitf !recv
    No incoming connections received, likely NAT problems
  Incoming routing destroyed for 6B45A5DD5213684BBA0424F8C9212E017CB0C264

--------------------------------------------------------------------------------------------------------

On my router TCP and UDP Ports 6881 are forwarded and UPnP is also enabled.  I don't know what else to do.


I also can't use magnet links at all.

I just get:

Downloading From :magnet:?xt=urn:btih:881AE935D6FFAF62112BAFA1B116796B0EBD5F09&&&&...
Waiting for DDB initialization...
Searching...
Metadata download created
Trying secondary lookup service
Secondary lookup failed: no sources found
Found: 0
ERROR: No Sources Found For Torrent

I wonder if my ISP (Telstra) is actively blocking all ports known for bittorrent clients, with the assumption that all Australians use Bittorrent only for piracy. 

I am an Aussie, working on a public domain UltraHD Texture Pack for a retro video game and it will be so big in filesize (estimating 8-12Gb when complete) at the end it would be more feasable for people to use torrent to download it, particularly if they have poor connection speeds (Like 95% of Australia), and this is a perfect example of bittorrent being used for legal reasons.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Download/NAT issue time_wizard 2 67 02-19-2017, 03:48 PM
Last Post: time_wizard
Question Static IP only fix for NAT error, but now can't torrent through VPN Glorypants 0 115 02-12-2017, 08:35 PM
Last Post: Glorypants



Users browsing this thread: 1 Guest(s)