Vuze Forums

Full Version: global upload rate stopped working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Any help with this would be great.

I set the global upload rate to different values depending on the time of day - 110 kB/s when my ISP monitors activites, 220 kB/s when it doesn't.  I have a 2Mbps upload connection.  This has worked fine, however for the last few days, my upload speeds have dropped down to 20-30 kB/s speed unless I am downloading something.

I have just tried setting the global upload rate to unlimited and the upload speed quickly shot up to my full 2 Mbps capacity.

I therefore tried setting the global upload rate to 400 kB/s and I now getting the upload speeds I used to get at this time ~ 110 kB/s

There is no other activity happening through my router.

Any hints on what is going on or what I need to do would be really appreciated.

Upload speeds are governed not by your ability to push data to peers but by peers requesting data from you. If there aren't many peers out there that need data then you won't be able to upload very fast.

Check out the swarms you are connected to and their seed-to-peer ratio.