Vuze Forums

Full Version: Cannot download torrents
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I have had a recent issue that when I click on a torrent to download, it does not download in vuze. It would be great if someone could help. Thank You
I confirm that there is a bug making download of certain torrents impossible.

Java 1.8.0_51
 Oracle Corporation
SWT v4508, win32
Windows 7 v6.1, amd64
V5.6.2.1_B05/4 az3

On a (very well established) private tracker, there is a series of 14 DVD torrents, all uploaded by the same member, at the same time.
Download torrent_01, click Vuze Open Torrents, click Add Files, add torrent, than click OK, nothing happens.  Box closes.  Starting torrent in Vuze impossible
Repeat.  Same result.
Exit Vuze.  Restart Vuze.  Repeat.  Same result.
Use a different BT client. Load torrent_01, it loads just fine, download starts immediately.

Download torrent_02, click Vuze Open Torrents, click Add Files, add torrent, than click OK, Open Torrents Options box opens, everything works OK.

Try again torrent_01 in Vuze to see if Vuze "loosened up".  No luck, still nothing happens. Starting torrent in Vuze impossible.

Download torrent_03, click Vuze Open Torrents, click Add Files, add torrent, than click OK, nothing happens.  Box closes. Starting torrent in Vuze impossible.
Repeat.  Same result.
Exit Vuze.  Restart Vuze.  Repeat.  Same result.
Use a different BT client. Load torrent_03, it loads just fine, download starts immediately.

Try again torrent_03 in Vuze.  No luck, still nothing happens.

8 hours later torrent_01 finished uploading in the other BT client.
Trying once again to open (the already downloaded) torrent_01 in Vuze (to seed).  This time miraculously, it opens.  ?????

Now download torrent_04 and trying to start download in Vuze.  No luck getting Vuze to start it.  Starting torrent in Vuze impossible.   The other BT client has no trouble with it.

Trying torrent_05, that one works in Vuze right away.

Is the other client bitcomet?
Once again, torrent_06 in the series (see post above) CANNOT be loaded in Vuze.  Same exact torrent was successfully loaded in another BT client.
What is the other torrent client?
If you could send one of these bad torrents to I'll see if there's something weird about it
(08-27-2015, 09:58 AM)'GaryE' Wrote: [ -> ]What is the other torrent client?


That client has many issues . . . but generating torrent files which are only usable on other versions of that client is not one of those problems.  That is the current verision and it has been out for about 6 weeks so it is pretty unlikely that it has an unreported problem creating torrents only transmission can use.

It might be that the tracker has done something weird but that seems unlikely.  Vuze is a popular enough client that you would see mention of it in that torrent sites' forums.

Hmmmmmm could it be a wierd port issue?

Do you know how to check which port(s) transmission and Vuze are using?  It is possible that only one port is getting blocked by your ISP or firewall or security suite or something.  It would be very very rare but other than a bad .torrent file that is all I can come up with.

Hold on!!!

How are you running Transmission on Windows??????  The last time I checked it was only available on Unix and Mac.  I just verified that my memory is correct there is no Windows version of Transmission.  Something is not the way it seems.  LOL
I am posting this for the benefit of other Vuze users who may experience this issue.
After uninstalling, rebooting computer, and installing Vuze (going back a few releases), the problem did not clear.
Which indicates that either Vuze is not uninstalling some components, or Windows (or Java) changed some component (such as a .dll) that does not play nicely with Vuze.
In my case, the problem is that the "Options Dialog" (where you select folder/files destination and what files to download) does not open (which means I can not start a new download).
The workaround for me was:
- go to Tools>Options>Files and for the option "When opening a dialog show options dialog"
- Select "never again".

Of course, if you want the files to go to a specific place, you would also change the "Default Directory" and/or the "Completion Moving" locations.
If you do not want to download everything, you could later go to Torrent>Files tab and select files (and priorities) to download.

This should help in the short term those who can not get a download started in Vuze.
Hopefully we will find the faulty component that inhibits in some cases the "Options Dialog" from opening so a workaround will no longer be needed.
Next beta (B08) has some code added to verify the dialog location and also logs positioning info to the debug log, so please when this is built and you are running it revert your 'when opening a dialog' option and see if the problem either has been fixed or, if not, send over the resulting debug log
Will do!
I have installed the latest Beta build.

On my previous attempts (with previous Beta build and a few "regular versions" going back) I had a few torrents that refused to load (could not load for "download" and/or could not load after downloading with another BT client for "seeding").

I used the above posted workaround to finally get all those torrents loaded (for seeding).
As I know that I was supposed to try to duplicate the problem using this Beta build, I deleted from library one of the "problem" torrents and tried loading it again.
Sure enough, just like before, the dialog did not open.

I am now creating the LOG and will submit separately.
As far as Vuze knows it is opening a dialog in a seemingly valid location on your screen:

Opening torrent options dialog: disp=Rectangle {0, 0, 1600, 900},shell=Rectangle {898, 898, 959, 760} -> Rectangle {898, 898, 959, 760}

I'm going to go along with the idea that it is something to do with the dialog title - B09 has an advanced setting that allows you to change the dialog title.

When you have it running please go to Tools->Options->Mode and make sure you are 'advanced'. Then go to Tools->Options->Logging and go to the 'Advanced Settings' group near the bottom.



in the 'name' field and


in the 'value' field and hit the 'set' button.

Then trying opening one of the problem torrents.
Will do!
B09 installed.  Added items as instructed.  
Attempted load of DVD6.  Dialog did not open.  
Created log.  Sent separately.
Pages: 1 2