Vuze Forums

Full Version: Vuze on Mac as User not Administrator
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I run Vuze on Mac OS X 9.x asa user without Admin rights. The admin user installed Vuze in the /Applications folder for me.

When i run Vuze, it starts complain it needs admin rights to update. I can click this warning away.

When i try to download something it complains the folders do not exists. Even if i create the folders & then retry, it seems like nothing starts to download.

Installing the plugins locally in my user folder also fails.

I have to stay a non admin user for security reaso,ns, how can i get Vuze to function ?
If you go to Tools->Options and click on the Plugins entry in the left-tree the right panel shows two folder locations, one for shared plugins and one for per-user plugins.

For my user 'nonpriv' I get the following:

    /Users/nonpriv/Library/Application Support/Vuze/plugins   - user-specific location

    /Applications/ - shared ones

You should have full write-access to the '/Users/nonpriv/Library/Application Support/Vuze/' location (this folder is where Vuze stores all of your configuration data)

You only need write access to '/Applications/' when updating - this stores the main application and any shared plugins

When you go to Tools->Options->Files you should see a default save location similar to 

     /Users/nonpriv/Library/Application Support/Vuze/Documents/Vuze Downloads

and Tools->Options->Files->Torrents should have a save location similar to

    /Users/nonpriv/Library/Application Support/Vuze/torrents

both of which should be writable.

Is this what you have?
The ...User/library/Application Support/Vuze/.... was read only.

changhed to read/write & now its working