Vuze Forums

Full Version: Downloading at 30MB/s when I should be at 90MB/s
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I tried to download the same torrent with both my laptop, and my seedbox. Result, I got 20MB/s with laptop and approx. 130MB/s with seedbox.
I ran many speedtest, all the same : 950Mbps down, and 300Mbps down.

So here is my question, why am I only downloading at 20MB/s , when I've capacities to download at 100MB/s + ? It's not about seeds or the torrent, since on my seedbox I reach 120MB/s in 20-30 seconds without problem.
My ports used for both TCP & UDP by Vuze are 6881, both are open on my rooter. Firewall has inbound rules allowing Vuze. I feel like everything is settled correctly.
Any idea of how to fix this ?
I would also like to hear any tips on how to make sure Vuze is performing as well as it should.

Out of curiosity, have you had the opportunity to test a different BitTorrent application on your laptop (with a similar set of torrents) to see if it is program-specific? (Perhaps it would not be proper forum etiquette to name theĀ  program, but I would hope that clarifying if there are noteworthy performance differences using the same protocol on the same system, without being more specific, would help spur the conversation.)