Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
--restart comand line stopped working on 5.7.2
I run Vuze on Ubuntu.  The restart commend no longer works but did on 5.7.0.  Now it just tidily shuts down Vuze but does not start back up.
Is it possible that the restart is failing due to Vuze not closing tidily? I ran some tests and for me it works fine when there are no closedown issues, however I did see if fail once when it had to force close due to a plugin (I2PHelper) not exiting cleanly.
For info - when the restart failed I got a thread dump in the console followed by

DEBUG::Tue Jul 12 14:31:35 PDT 2016::com.aelitis.azureus.core.impl.AzureusCoreImpl$15::perform::1531:
  Shutdown blocked, force exiting
    runSupport (, run (, runIt (, run (, run (
Exit from Azureus complete
No shutdown tasks to do

When it works I get

Exit from Azureus complete
Applying (possible) patches before restarting..
Restarting Azureus..
Starting Azureus...
java version "1.6.0_35"
OpenJDK Runtime Environment (IcedTea6 1.13.7) (6b35-1.13.7-1ubuntu0.10.04.2)
OpenJDK Server VM (build 23.25-b01, mixed mode)

Tried reseting my profile, a fresh install has the same problem.  Rolled back to 5.7 today and no issues.
How about console logs where it failed? Anything similar to the above?

I've improved the restart handling should shutdown fail in the next beta of 5721 in case that was the problem

Possibly Related Threads...
Thread Author Replies Views Last Post
  RSSfeed Scanner Plug-in stopped working Havokdan 0 3,549 01-27-2017, 08:53 AM
Last Post: Havokdan
  Subscription Schedule Check Not Working LuvVuze 2 4,165 11-15-2016, 11:22 PM
Last Post: LuvVuze

Users browsing this thread: 1 Guest(s)