Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
open torrent dialog problem on KDE

So I've upgraded to vuze which also came with a new SWT and with this new version the open torrent dialog is useless. I have two computers both running Kubuntu but with different versions.

One of them has kubuntu 14.04. On this the open torrent dialog appears but I cannot click any control on it except the bottom ok and cancel buttons. However I can move on the controls using the keyboard (tab etc). Also, on this computer, when I open the about dialog, from which I'm supposed to copy&paste here, the system section does not appear, only the top half of the first line which reads "Java 1.7.0_72" I suppose. The text is not selectable, which it should be.

On my other computer the situation is worse. That is an older computer with an older kubuntu (12.04.5). When I try to open a torrent azureus crashes. On this one the about dialog works correctly, here is the system info:
Java 1.7.0_72
 Oracle Corporation
SWT v4508, gtk
Linux v3.2.0-72-generic, amd64
V5.5.0.1_B06/4 az2
As you can see, on this one I joined the beta channel.
This is what appears on the console before crashing:
DEBUG::Tue Dec 02 12:58:49 EET 2014::org.gudy.azureus2.core3.util.DebugLight::printStackTrace::35:                                                                                                                               
        at com.aelitis.azureus.ui.swt.shells.opentorrent.OpenTorrentOptionsWindow$OpenTorrentInstance$32.runSupport(                                                                          
        at org.gudy.azureus2.ui.swt.Utils.execSWTThread(                                                                                                                                                          
        at org.gudy.azureus2.ui.swt.Utils.execSWTThread(                                                                                                                                                          
        at com.aelitis.azureus.ui.swt.shells.opentorrent.OpenTorrentOptionsWindow$OpenTorrentInstance.updateFileButtons(
        at com.aelitis.azureus.ui.swt.shells.opentorrent.OpenTorrentOptionsWindow$OpenTorrentInstance$1.toDownloadChanged(
        at org.gudy.azureus2.core3.torrent.impl.TorrentOpenOptions.fileDownloadStateChanged(
        at org.gudy.azureus2.core3.torrent.impl.TorrentOpenFileOptions.setToDownload(
        at org.gudy.azureus2.core3.torrent.impl.TorrentOpenFileOptions.<init>;(
        at org.gudy.azureus2.core3.torrent.impl.TorrentOpenOptions.getFiles(
        at com.aelitis.azureus.ui.swt.shells.opentorrent.OpenTorrentOptionsWindow$OpenTorrentInstance.setupTVFiles(
        at com.aelitis.azureus.ui.swt.shells.opentorrent.OpenTorrentOptionsWindow$OpenTorrentInstance.initialize(
        at com.aelitis.azureus.ui.swt.shells.opentorrent.OpenTorrentOptionsWindow$OpenTorrentInstance.access$1700(
        at com.aelitis.azureus.ui.swt.shells.opentorrent.OpenTorrentOptionsWindow.addInstance(
        at com.aelitis.azureus.ui.swt.shells.opentorrent.OpenTorrentOptionsWindow.swt_addTorrent(
        at com.aelitis.azureus.ui.swt.shells.opentorrent.OpenTorrentOptionsWindow$4.runSupport(
        at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(
        at org.eclipse.swt.widgets.Display.runAsyncMessages(
        at org.eclipse.swt.widgets.Display.readAndDispatch(
        at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>;(
        at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(
        at com.aelitis.azureus.ui.swt.Initializer.<init>;(
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
        at java.lang.reflect.Constructor.newInstance(
        at org.gudy.azureus2.ui.swt.Main.<init>;(
        at org.gudy.azureus2.ui.swt.Main.main(
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        at com.aelitis.azureus.launcher.MainExecutor$

java: /build/buildd/gtk2-engines-oxygen-1.2.2/src/animations/oxygencomboboxdata.cpp:87: void Oxygen::ComboBoxData::setButton(GtkWidget*): Assertion `!_button._widget' failed.
/home/soger/Azureus/azureus: line 204:  4681 Aborted                 ${JAVA_PROGRAM_DIR}java "${JAVA_ARGS}" -cp "${CLASSPATH}" -Djava.library.path="${PROGRAM_DIR}" -Dazureus.install.path="${PROGRAM_DIR}" -Dazureus.script="$0" $JAVA_PROPS $START_CLASS "$@"
Exit from Azureus complete
No shutdown tasks to do


In the meantime I figured out by myself, that the problem is with the SWT you guys supply: 4.508. I've downloaded the latest stable version from which is 4.427 and that one works correctly.
Now the problem is that vuze keeps popping up the window to update SWT, which is very annoying. What should I do?
(12-18-2014, 06:06 AM)'soger' Wrote: In the meantime I figured out by myself, that the problem is with the SWT you guys supply: 4.508. I've downloaded the latest stable version from which is 4.427 and that one works correctly.
Now the problem is that vuze keeps popping up the window to update SWT, which is very annoying. What should I do?


Can you check what version of GTK2 you have on your machines (should be a terminal command like dpkg -l libgtk* | grep -e '^i' | grep -e 'libgtk-*[0-9]'  )?  Apparently SWT/Eclipse is now requiring GTK+ 2.18.0 or higher for their 4.5xx builds.  Used to be 2.10.0 or higher.

Also, can you try 4.509 and see if they fixed it?
or 32 bit:

Sorry for my very late response, for some reason I assumed I'll get an email notification if anyone replies.

So, your command lists two gtk packages (actually 5 packages in total), I'll copy both versions here:
libgtk-3-0 3.10.8-0ubuntu1.4
libgtk2.0-0 2.24.23-0ubuntu1.1
seems ok, doesn't it?

Also, I've tried swt 4.509 but it also doesn't work.
Now what?

BTW, I disabled the automatic update check, I do it manually from time to time.
I browsed around on the eclipse website and I found a newer swt version, this one:
This one works almost perfectly on kubuntu 14.04, the only problem I found is that I can't copy&paste the sysinfo from the about vuze window, but the open torrent dialog works correctly. However on kubuntu 12.04 vuze still crashes when the open torrent dialog appears.

Possibly Related Threads...
Thread Author Replies Views Last Post
  wanneer gaat holland casino amsterdam west open 0 848 06-21-2022, 11:51 AM
Last Post:
  Deleting torrent delete .torrent file fields 3 6,341 12-14-2016, 06:09 PM
Last Post: nimack

Users browsing this thread: 1 Guest(s)