Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
azlocprov_0.1.7.5 Plugin Install (Permission Denied)
I'm on a mac running this:
Java 1.8.0_66 (64 bit)
 Oracle Corporation
SWT v4528, cocoa
Mac OS X v10.8.5, x86_64
V5.7.1.0/4 az2

I installed Vuze on a clean drive and upon launch it requests install of this plugin.  When installing I keep getting this error
    Downloading: [ torrent,,]
Torrent download complete
Installing plugin 'azlocprov/Location Provider', version
    Data verification stage complete
Version of plugin 'azlocprov/Location Provider' failed to install - /Users/XXXXXXXXX/Library/Application Support/Vuze/plugins/azlocprov/ (Permission denied)

Vuze original install came with azlocprov_0.1.7.4 and continues to ask me to update.  I tried to uninstall but it's still there after each launch asking me to update to azlocprov_0.1.7.5

For now as a temporary fix, I have turned off Plugin Updates in Preferences to prevent this annoying issue.
My router is configured properly so I'm not sure why I'm getting the error.  Please advise if you can help. TY
See if you can work out why write permission to

/Users/XXXXXXXXX/Library/Application Support/Vuze/plugins/azlocprov/

is absent.
'parg\' dateline='\'1460698333'' Wrote: See if you can work out why write permission to

/Users/XXXXXXXXX/Library/Application Support/Vuze/plugins/azlocprov/

is absent.


I was not able to find the reason why the Vuze Plugin install failed due to lack of permissions.  I tried doing it within Vuze plugin update system and also using the seperate download called azlocprov_0.1.7.5.vuze which opened Vuzed but still failed similarly due to the dreaded permission denied error.

I was able to manually install the update by locating the file and expanding it and replacing the 8 files from version 1.7.4 with the version 1.7.5 files (see screenshot).  I was asked to Authenticate the change and all was good.  I launched Vuze to turn on the Plugin Update notifications.  I then restarted Vuze.  It recognized the azlocprov_0.1.7.5 plugin as installed.  It seems ok for now although this is not how I want to update Vuze plugins in the future.

If anyone has any ideas as to why the Vuze Application Support doesn't have permissions to install or update, please give me your feedback. TY

Update: Using Get Info, I looked at the permissions on the folder for the older azlocprov_0.1.7.4 folder which had system (Read & Write), staff (Read only), & everyone (Read only).  I had to Authenticate to move it.
Permissions on the folder for the new azlocprov_0.1.7.5 folder which had XXXXXXXX (Me) (Read & Write), everyone (No Access)

Maybe one or both of these are wrong.  I made no change to either of these folders. Maybe someone could locate their version of this plugin folder and see what they have as permissions.

Attached Files Thumbnail(s)
I am having the exact same issue - also on a Mac, but running OX 10.11.4. I read through the prior posts in this thread and can san without hesitation that what you are talking about as a fix is WAY beyond my comfort zone. Everytime I sign in the update downloads and I get the same failure message due to denied permissions. And everytime I sign in i get the "Tahnks for upgrading to Vuse+" welcome. Suggestions?
Again, I had to manually install a plugin...

Currently Running on this:
Java 1.8.0_92 (64 bit)
 Oracle Corporation
SWT v4528, cocoa
Mac OS X v10.11.6, x86_64
V5.7.3.0/4 az2

I just updated Vuze tonight and had the same install issue on another Vuze plugin due to "Permissions Denied" error.  The plugin was azmsgsync_0.7.7.jar was attempting to install over the older azmsgsync_0.7.6.jar.

Work around:
I had to locate the downloaded azmsgsync_0.7.7.jar file using a search looking for invisible files (I used Easyfind). I had to authenticate to remove azmsgsync_0.7.6.jar and once again when I placed azmsgsync_0.7.7.jar into the the azmsgsync Plugin folder located in /Users/XXXXXXXXX/Library/Application Support/Vuze/plugins/azmsgsync/

Vuze is running with no errors and if I check for updates, it says it is "up to date".

Possibly Related Threads...
Thread Author Replies Views Last Post
  Can't install latest Vuze on OSX 10.14.3 sorcerer2020 0 3,075 12-24-2018, 10:18 PM
Last Post: sorcerer2020
  Auto-Shutdown Plugin? BigBad64 2 6,998 03-26-2018, 02:17 PM
Last Post: Havokdan

Users browsing this thread: 1 Guest(s)