Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Webtorrent wss trackers not working
#1
Hi,

On my local machine I can get webtorrents (wss) to work with the Webtorrent Desktop client and in instant.io but for the life of me I can not get Vuze to work even with the premium edition I bought.

Other trackers work but all the webtorrent enabled wss trackers have an "Error Failed-1" notice for each of them.

Turned off all firewalls to see if that helped.

At first, the built-in Chromium was just crashing so I deleted the files in the Vuze folder for it and that is opening now with the webtorrent Vuze Chromium page but still the trackers are not connecting up or down for any that are wss.

Any ideas what this could be please?

~Gary.
Reply
#2
Can you send me one of the failing torrents? paul@vuze.com - thanks
Reply
#3
(12-31-2016, 09:51 AM)'parg' Wrote: Can you send me one of the failing torrents? paul@vuze.com - thanks

 


Every wss tracker is failing. Including for sintel. which of course has massive amounts of seeders.
https://webtorrent.io/torrents/sintel.torrent
Reply
#4
Works fine for me...

Is there anything in the console  (Tools->Options->Console) - you need to turn on logging first (Tools->Options->Logging)
Reply
#5
parg\ dateline='\'1483223869' Wrote: Works fine for me...

Is there anything in the console  (Tools->Options->Console) - you need to turn on logging first (Tools->Options->Logging)

 


I will do that thanks. Did you just download it or look at the trackers and see which ones are working or not? With all due respect. Please.

Have the same issue on every computer I have tried it with. It seems like that function doesnt work anymore and its why I bought Vuze recently.

Update: logged to file. Nothing much for those trackers. Just that the tracker seem to want to append a key to the request and didnt. Null returned. Fail 1 error. 

For all wss trackers and all the others are fine.
Reply
#6
I downloaded the sintel movie using that torrent, after deleting the non-wss trackers and the http seed.

Can you paste the 'about' information from Vuze (Help menu, About Vuze, copy+paste the information in the 'System' area)?
Reply
#7
(12-31-2016, 04:50 PM)'parg' Wrote: I downloaded the sintel movie using that torrent, after deleting the non-wss trackers and the http seed.

Can you paste the 'about' information from Vuze (Help menu, About Vuze, copy+paste the information in the 'System' area)?

 

Java 1.8.0_111 (64 bit)
 Oracle Corporation
c:\program files (x86)\java\jre1.8.0_111

SWT v4508, win32
Windows 10 v10.0, x86
V5.7.4.0/4 az3

This?
I thought it maybe the bits of Java and Vuze mismatching but they
are both in an x86 folder.  So seemed ok to me. Plus, I get the same prob on my linux VPS.
Reply
#8
Weird - can you generate a 'debug.zip' (Help menu, last option), select the 'manual send' option and send it to paul@vuze.com?

Thanks!
Reply
#9
(12-31-2016, 06:26 PM)'parg' Wrote: Weird - can you generate a 'debug.zip' (Help menu, last option), select the 'manual send' option and send it to paul@vuze.com?

Thanks!

 


Done. Nice feature. Thanks again for helping with this. I really need it.
Reply
#10
(12-31-2016, 06:26 PM)'parg' Wrote: Weird - can you generate a 'debug.zip' (Help menu, last option), select the 'manual send' option and send it to paul@vuze.com?

Thanks!

 


Hi Paul, just wondering if you got the email? I know it's new years though so if you are away I hope you are having a good one. =)
Reply
#11
Hi,
Got it, thanks - nothing obvious in the logs unfortunately :( You might want to uninstall the 'Swarm Screen' plugin though, it is throwing a few errors and isn't a very useful plugin.

Have you looked at Tools->Plugins->Log Views->Web Torrent to see if there are any errors reported there?
Reply
#12
(01-01-2017, 06:44 PM)'parg' Wrote: Hi,
Got it, thanks - nothing obvious in the logs unfortunately :( You might want to uninstall the 'Swarm Screen' plugin though, it is throwing a few errors and isn't a very useful plugin.

Have you looked at Tools->Plugins->Log Views->Web Torrent to see if there are any errors reported there?

 


I have done but it just said nothing is being returned for those trackers. "NULL". 

Do they work for other people with Vuze? It doesnt work for me on Linux or windows either at home or the VPS servers I have tried.
Reply
#13
I've not tried Windows 10 but I have a few Windows 7 machines and it works fine. So the Chromium web browser proxy opens and shows a view something like this?

[Image: 37YTGf5EtYOc.png]

If so, can you open the 'inspector' and check the console for any messages?
Reply
#14
parg\ dateline='\'1483404757' Wrote: I've not tried Windows 10 but I have a few Windows 7 machines and it works fine. So the Chromium web browser proxy opens and shows a view something like this?

[Image: 37YTGf5EtYOc.png]

If so, can you open the 'inspector' and check the console for any messages?

 

Thanks for the effort. I am baffled. Yes it looks like that in Chromium for me but without the active webtorrents even though I have some in Vuze. 

I wouldnt be so confused if the Webtorrent Desktop app and other trackers were not working too. Plus, if it was working on my server, but UDP trackers are fine and webtorrents neither work at home or on the server. Different operating systems too. 

It is like I have missed a setting but there isnt many for the webtorrent plugin at all. It isnt a custom tracker. Just the normal ones people use. 

wss://tracker.btorrent.xyz

wss://tracker.fastcast.nz

wss://tracker.openwebtorrent.com

wss://tracker.btorrent.xyz

wss://tracker.fastcast.nz

wss://tracker.openwebtorrent.com

A friend of mine was able to get it to work. Which is great. At least I know it possible but doesnt seem to like me. lol.

I really need this to work. I invested a lot of money into the project.
Reply
#15
Just tested in fully updated Windows 10 and Kubuntu 16.04 VMs and everything worked fine - I am at a loss!
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
Question mlDHT not working with IPv6 psychic717 1 763 06-15-2017, 05:22 AM
Last Post: detelosk
  How do I get LAN peer transfer working with a VPN? gALANE 0 366 03-10-2017, 10:39 PM
Last Post: gALANE



Users browsing this thread: 1 Guest(s)