Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vuze thinks another copy is running, but there isn't; how to do a startup argument?
#1
"Another copy of Vuze appears to be running: failed to lock file
C:\Users\monok\AppData\Roaming\Azureus\.azlock
Vuze will now close."

C:\Users\monok\AppData\ doesn't exist. My AppData folder is now in \Bani\AppData. Even with hidden files shown, the folder does not exist.

Uninstalled and reinstalled 3 times. Deleted leftover files in-between. The last time, I even got rid of a bunch of relevant registry files. That did nothing.
No Vuze-related processes seem to be running in the background.

This page says:If you really want to disable this behaviour then there is a startup argument you can supply to do so:
 
PHP Code:
azureus.instance.lock.disable=
I have no idea how to do a startup argument and googling it for over an hour did nothing to help.
All the things I entered into the command line were wrong and did nothing.


For the love of all that is unholy, please help.
Reply
#2
You have a bigger problem than just the location of that lock file if your AppData folder is somewhere other than Vuze thinks it should be.

Did you rename your user from 'monok' to 'Bani' ? Not that this explains why Vuze is looking in the wrong place - Vuze asks Windows for the location, unless you've already set azureus.config.path, but this seems unlikely as you don't appear to know how to do this. If something goes wrong when asking Windows then Vuze will attempt to use an environment variable named 'APPDATA', you can check the value of this by opening a command prompt and entering 'set'

I guess that you could go ahead and create a C:\Users\monok\AppData\Roaming folder with full write permissions for your user but that isn't really a good solution...
Reply
#3
I have the same issue.   I've renamed my windows profile and it is looking to the old profile for the file to lock but the folder doesn't exist.

I've uninstalled - looked for remnant vuze directories but I can't resolve the issue -

"Another copy of Vuze appears to be running: failed to lock the file  -
C:\users\boe\appdata\roaming\azureus\.azlock
  - there is no users\boe directory so it is going to have a hard time finding it.  The correct directory is c:\users\bdillard\appdata\roaming\azureus and it does create that folder but doesn't seem to know to go to it.

All my other programs run fine.    I sure wish I knew how to change where it is searching.

I'd be curious how to run that startup thing as well but it doesn't tell you how to do that either.

It shutsdown on startup after displaying this message so there is no chance to change any options from within vuze.
Reply
#4
(01-04-2016, 12:49 PM)'boe' Wrote: I have the same issue.   I've renamed my windows profile and it is looking to the old profile for the file to lock but the folder doesn't exist.

I've uninstalled - looked for remnant vuze directories but I can't resolve the issue -

"Another copy of Vuze appears to be running: failed to lock the file  -
C:\users\boe\appdata\roaming\azureus\.azlock
  - there is no users\boe directory so it is going to have a hard time finding it.  The correct directory is c:\users\bdillard\appdata\roaming\azureus and it does create that folder but doesn't seem to know to go to it.

All my other programs run fine.    I sure wish I knew how to change where it is searching.

I'd be curious how to run that startup thing as well but it doesn't tell you how to do that either.

It shutsdown on startup after displaying this message so there is no chance to change any options from within vuze.

 

I use Windows 7 and the below process worked for me.
Copy the line below :
azureus.instance.lock.disable=1
and paste it to :
C:\Program Files\Vuze\Azureus.properties
By default, Windows won't recognise .properties file, therefore, right click > Open > Notepad or any other editor program you preferred.
Restart Vuze and the lock will no longer active.
Reply
#5
I use Windows 7 and the below process worked for me.
Copy the line below :
azureus.instance.lock.disable=1
and paste it to :
C:\Program Files\Vuze\Azureus.properties
By default, Windows won't recognise .properties file, therefore, right click > Open > Notepad or any other editor program you preferred.
Restart Vuze and the lock will no longer active.
Reply
#6
I tried creating the boe\appdata\roaming\azureus folder and copying the .azlock file there and it still comes up with the same message.
Reply
#7
Thanks for explaining how to put that entry in.  I can open Azureus now!
Reply
#8
(01-05-2016, 07:15 AM)I'm still confused on how you do that and where to find C:\Program Files\Vuze\Azureus.properties. I don't understand where i paste this link to. Please help because i really need to get vuze working. 'witarki' Wrote: I use Windows 7 and the below process worked for me.
Copy the line below :
azureus.instance.lock.disable=1
and paste it to :
C:\Program Files\Vuze\Azureus.properties
By default, Windows won't recognise .properties file, therefore, right click > Open > Notepad or any other editor program you preferred.
Restart Vuze and the lock will no longer active.

 
Reply
#9
(11-22-2015, 04:56 PM)'Baniita' Wrote: "Another copy of Vuze appears to be running: failed to lock file
C:\Users\monok\AppData\Roaming\Azureus\.azlock
Vuze will now close."

C:\Users\monok\AppData\ doesn't exist. My AppData folder is now in \Bani\AppData. Even with hidden files shown, the folder does not exist.

Uninstalled and reinstalled 3 times. Deleted leftover files in-between. The last time, I even got rid of a bunch of relevant registry files. That did nothing.
No Vuze-related processes seem to be running in the background.

This page says:If you really want to disable this behaviour then there is a startup argument you can supply to do so: 
PHP Code:
azureus.instance.lock.disable=
I have no idea how to do a startup argument and googling it for over an hour did nothing to help.
All the things I entered into the command line were wrong and did nothing.


For the love of all that is unholy, please help.



 

Here's the solution for anyone still having this problem, I too changed my windows user account name from generic "User" which I initially created my account with, to my actual name. I got the same Issue from vuze. Here's how I completely fixed mine. 

-Note: <config_new> here/below refers to the new folder you want to move your vuze folder to. 

-Also, anywhere you see <config_new> below, in your case, replace it with "C:\Users\Bani\AppData\Roaming\Azureus" without quotes. The same goes for anyone else doing this, replace <config_new> with THE FULL ABSOLUTE PATH of your new AppData folder. 

-Firstly backup your old config folder, Usually it's your new/current "Appdata\roaming\Azureus", then delete all the files currently in there. Close vuze completely if it's running, then follow the steps below.

1. In your vuze installation directory, Usually in "Program Files\Vuze", locate the "Azureus.exe.vmoptions" file.
2. Edit this file, it's best to copy it out to your desktop to make things easier. Open it up with notepad and you'll want to do two things. 
2a) Add this line "-Dazureus.config.path=<config_new>", without quotes 
2b) If you see this line "-include-options ${APPDATA}\Azureus\java.vmoptions",  You should replace it with "-include-options <config_new>\java.vmoptions" without quotes
3) Now save the file, if you moved it out to edit, move it back to your installation directory.

Now restart vuze and everything should work fine now. I hope that helped.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Vuze won't startup on login Grego 0 225 04-17-2017, 08:09 AM
Last Post: Grego
  Vuze crashes on startup after update 5.7.5.0 lottemann 4 469 03-21-2017, 02:58 PM
Last Post: lottemann



Users browsing this thread: 1 Guest(s)