Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vuze on Linux fails after update
#1
Installed Vuze under Linux, program initially opens up, then says an update has been downloaded, and Vude needs to restart to install.  After shutdown, Vuze is never able to restart.  The problem seems to be with the swt.jar file, the following is the error I am seeing when vuze tried to start up after the update:

changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (United States)' (en_US)
, using 'English (default)'
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
rce)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at org.gudy.azureus2.ui.swt.Main.<init>;(Main.java:111)
        at org.gudy.azureus2.ui.swt.Main.main(Main.java:334)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at com.aelitis.azureus.launcher.MainExecutor$1.run(MainExecutor.java:34)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
        no swt-pi-gtk-4716 in java.library.path
        no swt-pi-gtk in java.library.path
        /root/.swt/lib/linux/x86_64/libswt-pi-gtk-4716.so: /lib64/libc.so.6: ver
sion `GLIBC_2.14' not found (required by /root/.swt/lib/linux/x86_64/libswt-pi-g
tk-4716.so)
        Can't load library: /root/.swt/lib/linux/x86_64/libswt-pi-gtk.so

        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:327)
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:236)
        at org.eclipse.swt.internal.gtk.OS.<clinit>;(OS.java:34)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
        at org.eclipse.swt.widgets.Display.<clinit>;(Display.java:140)
        at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>;(SWTThread.java:8
3)
        at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThrea
d.java:61)
        at com.aelitis.azureus.ui.swt.Initializer.<init>;(Initializer.java:160)
        ... 12 more
Exit from Azureus complete
No shutdown tasks to do
Azureus TERMINATED.

If I remove the swt.jar file, Vuze can start, but it immidiately says the update has been downloaded and vuze needs to restart to update again.  Any help would be appreciated..
Reply
#2
Looks like your GLIBC is too old to run the new SWT :(
Try

sudo apt-get install libc6
Reply
#3
(02-10-2017, 11:57 AM)'ArronM' Wrote: Looks like your GLIBC is too old to run the new SWT :(
Try

sudo apt-get install libc6

 

Unfortunatly this is CentOS 6.8 not Ubuntu, and libc6 is not available.  glibc is the latest version for CentOS

[root@server ~]# yum install glibc
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.fileplanet.com
 * centosplus: mirror.fileplanet.com
 * contrib: mirror.fileplanet.com
 * extras: mirror.fileplanet.com
 * rpmfusion-free-updates: lug.mtu.edu
 * rpmfusion-nonfree-updates: lug.mtu.edu
 * updates: mirror.fileplanet.com
Package glibc-2.12-1.192.el6.x86_64 already installed and latest version
Nothing to do
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Vuze crashes windows 7x64 when checking a file after starting a stopped file MisterFixIt1952 2 1,969 12-18-2017, 11:26 PM
Last Post: ekstasee
  New Vuze update broke VPN Helper camaro1919 5 6,516 11-18-2017, 11:45 AM
Last Post: Hodag



Users browsing this thread: 1 Guest(s)