Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vuze keeps changing my port settings
I'm running Vuze inside a VMware Win8.1 virtual machine. As soon as the VM starts it switches to a PIA VPN connection with port forwarding enabled. This worked great with Vuze up until recently, and I'm not sure how but Vuze always knew what port was assigned by PIA and configured itself to use that port for TCP and UDP connections. All of a sudden though this stopped working. Every time Vuze starts now it sets the TCP and UDP ports to 45091 even though that is not the port assigned by PIA. If I manually change the ports in Options it only sticks for about ten seconds and then reverts to 45091 again. BTW... not sure if it is supposed to work this way but clicking the "Save" button doesn't close the Options window. In fact, there is no indication that anything has happened after the Save button is clicked.

Before anyone asks, I do NOT have Vuze set to randomize ports on startup. PIA doesn't allow you to specify the forwarded port so I can't tell it to use 45091. I have a suspicion this may actually be a PIA problem because I think it started just after I installed an update to the PIA client app a whle back. I'm thinking that perhaps Vuze asks the VPN what port to use and PIA is reporting the wrong value. I was hoping a future client update would fix it but i just installed another new one from PIA today and the problem remains. Does anybody have any idea what is happening and how to fix it? If I can't solve this I'm going to have to change my bittorrent client, which I don't want to do.
Are you using the VPN Helper plugin in Vuze?  If you are, you can see it's state with View->VPN Helper.  It should display something similar to this:

[Image: iaTnYFj.png]

If you have not set the user/pw in VPN Helper's config, it'll say something along the lines of "Port read from PIA config" (can't remember the exact text).  It's possible the latest version of the PIA Manager doesn't write the port to the config anymore (but I haven't heard any other reports, so I'm hoping that's not the issue)
Yeah, I figured that out about a half hour after posting that original cry for help, but it was in moderation for quite a while so I couldn't go back and edit it. It was indeed VPN Helper that was causing the problem. It appears that something changed with the last two releases of the PIA client app so that VPN helper no longer retrieves the port number properly. I tried playing with the regular expression setting in the VPN Help configuration with no luck. I'm actually a bit of a RegEx nerd so if I understood where the plugin is trying to pull the port from I might be able to get it working, but the default RegEx seems to match Ok so I'm guessing that the port number has just been moved somewhere else relative to the IP address wherever VPN Helper is grabbing it from.

For now I have disabled VPN Helper and can now manually set the TCP and UDP ports without them changing back to the wrong value two seconds later, but this is obviously not the preferred solution since PIA periodically changes the forwarding port it assigns me. I'd like to report this to the VPN Helper dev but don't know how to do it.

EDIT: Should have mentioned... the VPN Helper status display says everything is fine, but clearly it's not.
I'm the plugin developer, so your comments have been noted :)

The port check logic isn't very robust, so as long as it gets a port number, it just assumes everything is ok.

The port is retrieved separately from the ip address. PIA has a specific RPC for it if you enter your login information. If you don't, I read it from the config file. The regex is only for detecting which interface could potentially be PIA (since PIA uses a specific local ip range)

I'll try upgrading my PIA test machine to see if I can reproduce it. Personally, I still use v.63 of their PIA Manager, because future versions f**k with DNS entries too much for my liking.
PIA completely rewrote their client app a little while back, and as soon as I installed that update the port detection stopped working. If I entered my PIA login details to the plugin would that help your plugin figure out the port?

PIA doesn't change my assigned port very often so it's not a deal breaker if I have to manually set the Vuze port numbers until you figure this out. Thanks.
This has receently been happening to me since the newest Vuze update.
I'm not as proficient as the orginal poster, so not sure what has to be done to fix this.
Using Vuze

As orginal poster stated, the incoming  TCP/UDP always used to match up with what PIA assigned.
All I used to do is copy paste that port # into Advanced Network Settings -> Bind to local port 
(saw that on another thread/post once and been doing it ever since)

Thanks, and let me know if any other information is needed.

Possibly Related Threads...
Thread Author Replies Views Last Post
Question Testing TCP port 61351 inbound VuzeDude 2 12,758 10-13-2018, 03:59 AM
Last Post: VuzeDude
  VPN (PIA) showing different Port to Vuze? BigBad64 0 5,765 03-25-2018, 01:37 PM
Last Post: BigBad64

Users browsing this thread: 1 Guest(s)