Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vuze crashin when adding torrent file
Everything was working normally until this last update (

When I try to open a torrent file, it shows that window with options where it should be saved among many other, but it crashes almost immediately not even writing anything in any .log file in .azureus/log directory. I already tweaked JAVA_ARGS option in startup script setting it to "-Xmx2048m". Tried different amounts of memories ranging from 512 MB to 4096 MB. Tried disabling almost all plugins, I only left uPnP Media server (which seems it cannot be removed for some reason, but I wanted it to be removed too), uTP Plugin and Vuze Feature Manager.

Using Kubuntu 14.04 64-bit, completely updated with newest Java version available in regular repo. I can't imagine living without Vuze, really. Please help.
Check regarding the SWT version ?
I just managed to load torrent, but I had to change export SWT_GTK3 to 1 in vuze startup file. Then interface was broken, but dropdown menus was working and I successfully loaded the torrent. Still, it's not usable with GTK3, and this is just a temporary workaround for loading torrents.
Hmm... oh wait. I just managed to load torrent with SWT_GTK3=0. Now nothing is logical if you ask me.... Will try another one now and it... works!

This is Vuze's about section:

Java 1.7.0_65
Oracle Corporation
SWT v4508, gtk
Linux v3.13.0-39-generic, amd64
V5.5.0.0/4 az3

P.S. really weird shit if you ask me.
Very weird... Glad it is sorted though, hope it stays that way!
(11-22-2014, 06:23 PM)'parg' Wrote: Very weird... Glad it is sorted though, hope it stays that way!


i have exactly the same problem.
here is the exception :
Vuze:10582): GLib-CRITICAL **: Source ID 3996 was not found when attempting to remove it
java: /build/buildd/gtk2-engines-oxygen-1.4.5/src/animations/oxygencomboboxdata.cpp:87: void Oxygen::ComboBoxData::setButton(GtkWidget*): Assertion `!_button._widget' failed.
./vuze: line 204: 10582 Aborted                 (core dumped) ${JAVA_PROGRAM_DIR}java "${JAVA_ARGS}" -cp "${CLASSPATH}" -Djava.library.path="${PROGRAM_DIR}" -Dazureus.install.path="${PROGRAM_DIR}" -Dazureus.script="$0" $JAVA_PROPS $START_CLASS "$@"
Exit from Azureus complete
 System info:
Java 1.7.0_65
 Oracle Corporation
SWT v4508, gtk
Linux v3.16.0-24-generic, amd64
V5.5.0.1_B03/4 az3

Even join the BETA program, same issue there. I am trying your export 'fix' next.

looks like this is the culprit :
"Workaround: System Settings > Application Appearance > GTK > Set GTK2 theme to "Redmond" or others (Clearlooks works too)."

I can confirm this work-around works. It will prob be some time before the bug fix is integrated in ubuntu.
nice catch!

Possibly Related Threads...
Thread Author Replies Views Last Post
Photo Vuze downloads more than the file size. Buddyboy 0 2,944 02-24-2019, 02:02 PM
Last Post: Buddyboy
  download history file location snapshot1219 3 8,797 12-11-2018, 03:01 AM
Last Post: snapshot1219

Users browsing this thread: 1 Guest(s)