Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Using tags to add and remove trackers
Deleting dead trackers lead me to adding live trackers. Then I realized I should not add public trackers to my torrents from my private trackers. so my current setup is a tag 'foo' with this constraint: !hasTag( "" ) && !hasTag( "" ) && !hasTag( "" ) &&  !isComplete()
to which I merge a tracker template, called 'added trackers'.

Unfortunately at least some (looks like maybe all) new private tracker torrents get the public tracker list added.

So I set my 3 private tracker tags to remove the tracker template called "added trackers". The first tracker on the list does NOT get removed.

This is very strange because I have a template called 'bar' with the same constraint as 'foo' which removes the tracker template called 'dead trackers' and as far as I can tell the first on the list does get removed.
The the tracker in question is


I moved it to the bottom of the list with the same result that it does not get removed. It seems the :2710 is the problem as when I go to remove it manually is is always something else of the form :27n0 where n=2..9

Other trackers that end with :80, :1337 and :6969 seem to stay fixed. I'm not sure what is so special about :2710?
There shouldn't be anything special about a given port number, they're all treated the same.

Could it just be an ordering issue? There is no deterministic order that auto-tags are applied in, so if the 'remove-trackers' was applied before the 'add-trackers' you'd end up with them being added and not subsequently removed.
There is something about udp:// that is causing the problem.

-I add a torrent from a private tracker
-the tag 'foo' gets applied to the torrent. The constraint of 'foo' is that there should be no private tracker id tag but it appears that 'foo' gets applied first
-'foo' has the action of merging/adding a list of trackers > 7 trackers get added
-the private tracker id tag gets applied.
-I have added the action of removing the same list of trackers to the private tracker id tags > 6 trackers get removed

I have tried having udp:// first, last and in the middle of the list. It is added but never removed. When I go to the sources tab the port number is changed to one of 2720/2730/.../2790/2800

Many public torrents already have the rarbg tracker so I have removed it from the list to get rid of the problem.
the '9' and '0' are the only things that look different to the other trackers so I am guessing they might be the source of the aberrant behaviour.
OK, I looked into it... and you're right. The reason though is that there is a 'standard' for a tracker to tell a client that it should use certain protocols/ports via a DNS TXT record. For we have: -> [BITTORRENT UDP:2740, BITTORRENT UDP:2710, BITTORRENT UDP:2720, BITTORRENT UDP:2770, BITTORRENT UDP:2780, BITTORRENT UDP:2790, BITTORRENT UDP:2800, BITTORRENT UDP:2730, BITTORRENT UDP:2750]

(you can see this in the evidence.log file generated when you create a file)


In your case the 2710 is being replaced with 2740 as that is preferred.

I will add a special case port of 0 that will cause the port to be ignored when removing trackers - i.e. you would place


in your removal template - check the next beta!
Actually, no change is required

Matching is done by prefix, so if you just enter


in your removal template then this will remove any URL that starts with that string.
That actually all made sense to me. Thanks.

Possibly Related Threads...
Thread Author Replies Views Last Post
  Restarting a torrent while using already downloaded data. Buddyboy 0 4,973 10-05-2018, 01:04 AM
Last Post: Buddyboy
  API to remove Stopped? jriker1 4 11,897 04-18-2018, 06:10 AM
Last Post: Havokdan

Users browsing this thread: 1 Guest(s)