Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOLVED: Remote Pairing + Explicit Attributes + Bind to local IP
#1
I have a dual Network Adapter (NIC setup).

NIC connection #1 goes over a regular Internet Connection.  (let's call this IP 192.168.1.1)
NIC connection #2 goes over a VPN connection.  (let's call this IP 10.10.10.10)

I use the Vuze setting under:  Options > Connection > Advanced Network Settings > "Bind to local IP or interface"

I set this to the 10.10.10.10, so that VUZE uses this specific NIC (#2) with a VPN attached to it.

As I would like to use the Vuze "Remote Pairing" feature, and I cannot use the VPN connection, I need to specify my normal Internet connection (NIC #1 / 192.168.1.1)

SO ->
I navigated to Options > Connection > Pairing |||  I see a section named "Explicit Attributes".

I set this section to use NIC #1 over 192.168.1.1 (Local IPv4 address).
I specifiy the public broadcast IP for this NIC that comes from my ISP.
I also specify a DNS name that points to this public brodcast IP that I get from Dynamic DNS.


However, when I use the "Tools" > "Remote Pairing" feature, I always get the "Vuze isn't accessible outside your local network" message.


BUT ->

If I change the "Bind to local IP or interface" from NIC #2 to NIC #1, Vuze Remote Pairing works perfectly fine.

Am I understanding the purpose of "Explicit Attributes"?

...  or is possibly a bug in Vuze, where the "Binding" IP setting overrides the "Explicit Attributes"?
Reply
#2
There are two things going on - the explicit attributes tell the 'pairing server' to use the values you supply rather than the ones that are deduced by Vuze connecting to the pairing server (when you bind Vuze to interface X then interface X will be used to contact the server and the server will see details of the X route). 

The pairing stuff works for a number of services, the 'Vuze Web Remote' is just one of them and it is supported by the 'Vuze Web Remote' plugin. This plugin has its own configuration under Tools->Options->Plugins->Vuze Web Remote and it has its own 'bind ip' config set there. By default this will inherit the global Vuze binding (X) and so the remote service will be listening on that interface. So you need to change that setting to listen on 192.168.1.1
Reply
#3
(01-31-2016, 11:11 AM)'parg' Wrote: There are two things going on - the explicit attributes tell the 'pairing server' to use the values you supply rather than the ones that are deduced by Vuze connecting to the pairing server (when you bind Vuze to interface X then interface X will be used to contact the server and the server will see details of the X route). 

The pairing stuff works for a number of services, the 'Vuze Web Remote' is just one of them and it is supported by the 'Vuze Web Remote' plugin. This plugin has its own configuration under Tools->Options->Plugins->Vuze Web Remote and it has its own 'bind ip' config set there. By default this will inherit the global Vuze binding (X) and so the remote service will be listening on that interface. So you need to change that setting to listen on 192.168.1.1

 


Thanks for the reply parg.

So I navigate to the "
Tools->Options->Plugins->Vuze Web Remote" page as you suggested, but I do not see any place where I can "Bind" an IP address to this service. (I'm using Vuze version 5.7.0.0)

[Image: bdc73bed72ad1318b1e4a3fe10654868]

Image Link:  https://gyazo.com/bdc73bed72ad1318b1e4a3fe10654868

From what I understand in the Wiki, is that "Vuze Web Remote" is supposed to control other instances of Vuze, from my local machine.
I am to control my only instance of Vuze, running locally, using the Android App.

Would you mind pointing me in the right direction, where I can tell Vuze to listen specifically to the NIC using 192.168.1.1 ?

Thanks again...
Reply
#4
You went to 

Tools->Plugins->Vuze Web Remote

whereas you need to go to the options panel and then navigate to the Vuze Web Remote under the 'Plugins' settings

Tools->OPTIONS... (->) Plugins->Vuze Web Remote

Confusing I know
Reply
#5
DUOH!
You are absolutely correct, I was reading "diagonally" > LOL LOL
Thanks for that.

So I found the setting, and put in my NIC #1 IP Address as my "Bind IP" in the "Tools->Options->Plugins->Vuze Web Remote" menu.  
I still yeild the same result of "Vuze isn't accessible outside your local network".

I also tested the 
"Tools->Options->Connection->Advanced Network Settings->Bind to local IP address or interface" again, changing the IP from NIC #2 to NIC #1 ( 10.10.10.10 to 192.168.1.1), and Remote pairing begins to work instantly.

I have included screenshots of these settings pages if that helps, let me know if there is something else I need to do.


It would be so great, if I could use Vuze with my VPN provider, but still access Vuze from my Android device over the non-VPN connection. Definitely blow any other tor-client out of the water! :)

Image 1
Advanced Nework Settings:

[Image: e7e0cc708cbbdfebe8dc3a95873b961c]

https://gyazo.com/e7e0cc708cbbdfebe8dc3a95873b961c

Image 2
Connection > Pairing

[Image: b195f33ad0fefe583b0567f040ba199f]

https://gyazo.com/b195f33ad0fefe583b0567f040ba199f

Image 3
Vuze Web Remote

[Image: c626db0db96f5026b7052cb045510eb9]

https://gyazo.com/c626db0db96f5026b7052cb045510eb9
Reply
#6
Hi everyone, I got this solved on my end, so I thought I would share.

(Disclaimer:  I'm not sure if 1 of these items made the difference, or ALL these items working together ended up solving issue)




1)   "Tools->Options->Plugins->Vuze Web Remote"
  • Enabled
  • Changed port from 9091 to a port in the 30000 range
  • "Bind IP - normally not required" = "192.168.1.1"
  • Un-check "Enable UPnP for this port"

(NOTE:  By doing this, you need to know how to specify the port, in your router firewall / options for port forwarding)


2)   "Options > Connection > Pairing |||  section named "Explicit Attributes"
  • Removed "Public IPv4 Address" (blank value)
  • Removed "Local IPv4 address" (blank value)
  • Left "Host Address (DNS name)" with DynamicDNS

(NOTE:  It seems that If I leave either "Public IPv4" or "Host Address (DNS name)" the feature will work, I cannot specifiy BOTH at the same time even though they are both valid - maybe an idea for interface enhancement)

3)  "Options > Plugins > UPnP"
  • Dissabled

(NOTE:  By doing this, you need to know how to specify the ports that you enter in ""Options > Connection", in your router firewall / options for port forwarding)



Hope this helps out with anyone else having similar issues of wanting to dedicate Vuze to run over a VPN, but still have remote control access from their mobile device.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  SOLVED: RSSFeed Scanner plugin hanging (forever) at "Connecting" FeRDNYC 4 292 04-10-2017, 10:39 PM
Last Post: parg
  Vuze Remote trouble, no remote services enabled?? vuzeRhino 2 269 04-06-2017, 03:12 PM
Last Post: vuzeRhino



Users browsing this thread: 1 Guest(s)