Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RSSfeed Scanner error- Malformed RSS XML: The entity "nbsp" was referenced, but not..
#1
I've had RSSfeed Scanner working for 2 sites for over a year, but a third site is sporadically giving me this error:

"Malformed RSS XML: The entity "nbsp" was referenced, but not declared."

When I get this, no torrent list is processed and I can't auto-download my torrents.
&nbsp
It appears to happen when certain torrents are uploaded to the site with the "nbsp" html entity in them in, maybe, the
title, but I'm not sure since I don't know how to see the XML that is obtained from the server.  The error goes away
periodically, I guess when the offending torrent description scrolls off the list being downloaded.  Since the site
shows no inclination of checking their XML better, I'm stuck with trying to figure out how to get around the error in RSSfeed.
I'm currently running Vuze 4.9.0.0 with RSSfeed Scanner V. 1.4.5.
I've tried installing Vuze 5.5.0.0 with RSSfeed S. V. 1.4.12.1 but I get the same error.

Running:
Java 1.7.0_05  Oracle Corporation
SWT v4233, win32
Windows XP v5.1, x86 [ SP3]
V4.9.0.0/4

I can't install any higher Java version than 1.7 on WINXP, in case that is part of the problem.

I can't seem to find anyone who has gotten this error and I can't find any supporting web page for RSSfeed. 
I'm wondering if anyone knows of how to tell RSSfeed to ignore the error or pre-define the "nbsp" entity so it won't complain about it ?  I would really appreciate any suggestions on solving this. 
Thanks.
 

 

 

 

 

 

 

 
Reply
#2
Join the Beta Program

http://wiki.vuze.com/w/Beta_Program

to update to version 5.6.0.1

Allow the latest version of rssfeed to install (version 1.4.15) and then see if that works.
Reply
#3
(03-04-2015, 03:13 PM)'parg' Wrote: Join the Beta Program

http://wiki.vuze.com/w/Beta_Program

to update to version 5.6.0.1

Allow the latest version of rssfeed to install (version 1.4.15) and then see if that works.


 
It's not that simple.  Didn't I read that Vuze 5.5.0.0 requires Java 1.8 ?  
I can't install Java 1.8 on WINXP.

 
Reply
#4
No, 5.5 and 5.6 require Java 1.5 or higher
Reply
#5
Thanks, I'll try that.
Is there somewhere I can look to see if RSSfeed Scanner has fixed any XML problems ?  A list of bugfixes and/or
existing problems or a web support page ?
The page under Vuze support says that the home web page for RSSfeed Scanner disappeared.
The page at "plugins.vuze.com/plugin_details.php?plugin=rssfeed"  is nice but not enough detail.

 

 
Reply
#6
I released version 1.4.15 yesterday as a fix to your problem...
Reply
#7
PARG -
Many, many thanks on this fix !
I'm now running Vuze 5.6.0.1_B03 and your RSSfeed 1.4.15_CVS and it looks like it's fixed (unless the bad XML rolled off the RSS feed during my re-install of both products). I don't usually like to run with bleeding-edge SW (my experience from Unix and MS bloatware) but it's worth it to have it fixed.
Extra congrads on this.

(If you feel like answering, to fix it, did you just recode RSSfeed so it wouldn't abort on the bad XML or did you put in some pre-definitions for the nbsp entity ? (Whenever I looked at the rssfeed.options file, it would always be full of the "nbsp" entity even when it was working, so I couldn't tell where it was complaining about the "nbsp" occurance).)
Reply
#8
PARG,
I have a new problem with Vuze 5.6.0.1 in that the site that was giving me the bad XML in the RSS feed (hd-torrents.org), says it won't permit Vuze version above 5.5.0.0 yet. Will this new RSSfeed 1.4.15 plugin work with Vuze 5.5.0.0 ?
Reply
#9
good question - best thing would just be to try and see...
Reply
#10
PARG,

I just installed Vuze 5.5.0.0 and RSSfeed 1.4.15 seems to work fine with it so far. No "Malformed RSS XML" and all torrents are working.
I do have a torrent - Azureus5601-B03-signed.jar - that's still there and seeding. I assume it's for Beta updates, so I don't know if it's getting bogus stuff because I'm running 5.5.0.0 now.
Should I delete it ?

I have only one display issue/error with 5.5.0.0 (and it was there with 5.6.0.1_B03 too), but I'll post that in another forum.

Thanks again !
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  RSSFeed Scanner trgarner 0 113 02-12-2017, 10:53 AM
Last Post: trgarner
  Is there a way to change the Status/Link time delay in RSSFeed Scanner? trgarner 2 221 02-02-2017, 07:33 PM
Last Post: trgarner



Users browsing this thread: 1 Guest(s)