Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Port Forwarding problem with PIA VPN- from Vuze Update?
#1
Recently I've had problems which turned out to be a failing HDD. That was the drive that had my Vuze Downloads folder on it. I've got a new HDD now, and have moved the Downloads folder to it; I've reset the Vuze Options/Files/Default Directory to the new address, and have reset the downloaded files themselves in the Library using Change Data Directory. All looks good, and my previously downloaded files are (mostly) showing green smilies, with a few blue and yellow. (I mention all this as background in case something happened that I'm not aware of, but it seems like my new HDD isn't the cause of the problem I'm now having. I was finished with all this last evening, and didn't expect any further problems.)

Then this morning when I started Vuze, I got a Vuze update. When the update was finished & Vuze had restarted, I noticed that VPN Helper for PIA was showing a yellow box with ??. When I opened up the Helper, I found that under Port Forwarding and IP Binding, everything was checked off as OK, except the last entry: "Could not get forwarding port. Ensure PIA Manager Directory is properly set, or set user/pass in plugin config." 

That has always been set exactly as directed. I double-checked, and yes the PIA Manager is set correctly, and the PIA_Manager.exe is there where the directory window indicates. Long ago I'd put in my username & password- and I did that again today; but the password only shows 3 characters. I tried saving it several times, but it never shows the correct number of characters (but I don't know if this is new behavior or whether it's always been like that.) Anyway, I still got the error message that it could not get forwarding port.

Next I checked PIA. It has been working flawlessly, and nothing seems amiss. I rechecked that it was set to forward the port, which it is; but Vuze isn't showing the port that PIA is forwarding. The Vuze NAT/Server Port Test says, "Testing port TCP 22380 ... /Unable to test: Invalid port given, or test service failed. /Another application may already be using this port.. /(Error: Unexpected end of file from server)." I've tried changing PIA to a different location & port #, but it makes no difference.  

I have re-started Vuze dozens of times, each time I tried to change something; nothing has had the slightest effect, and I still don't get any port forwarding. 

The last thing I tried was to reinstall Vuze from a backup; except for losing all my customization, nothing has changed. I don't know what else to try, so I sure hope someone can HELP ME! 

(LOL- I just previewed this post & discovered that as I'm brand new in this Forum, I'm a "leecher." It's true! I never even knew there was a Forum until today, and I'm sure hoping to leech some knowledge!- and if I ever get to know anything, I'll try to pass it on.)
Reply
#2
The 3 stars for the password is normal, even when your password is not 3 characters.

Does it also say
⌘ Invalid RPC result: {"error":"Unauthorized, please check username and password"}"

If so, then your username/pw set in VPN Helper config is definitely wrong.

or is there any other message in that section saying something about "RPC"?
Reply
#3
Thanks for the reply- but no, the error msg saying "Could not get forwarding port..." is all. Nothing about RPC. 

I'm glad to hear that at least it seems that my username/pass in VPN Helper is OK, that's one possibility of error eliminated. 

Since posting the above, I've found that I can actually download, or at least the one file I tried downloaded OK- but I don't know whether this is downloading through my VPN or in some other way, so I'm hoping to find a solution before doing any more downloading.

Oh, and I have tried to set the port # manually in Vuze, and Vuze then shows the same port that PIA does, but the results are still the same: "Could not get...." 

Is there a full diagnostic program or anything like that available to show where things are going astray? 

I've tried using the Vuze Configuration Wizard, with mixed results: M-Lab Speed Test Wizard tells me that I have Outbound 4.98 Mb/s, Inbound 2.75 Mb/s; "Slowest link in the end-to-end path is a 10 Mbps Ethernet subnet." There is some network congestion, and "Packet queueing detected." Completed: up=608.0 kB/s, down= 336.9 kB/s. Then things go wonky; and after that info, when I click on "next," all I get is a blank window with "next" or "finish" at the bottom. It doesn't matter which I click on, either choice does nothing. I have to click on the top-right X to close the window. I can't get the Wizard to continue, that's where it all stops.

Also, those numbers given by the test don't sound right, if things are working correctly. Usually I can download at up to 7-8 Mb/s, while uploading is usually limited to around 500 kB/s. SpeedTest gives my usual internet speed as >50 Mb/s down, >5 Mb/s up.

Is there anything else I can try? Somehow I think that there's just one thing set wrongly somewhere...! (And I sure wish I knew what it was!)
Reply
#4
Vuze is still binding to your VPN ok, so any connections will be going through the VPN. That means anyone you can connect to will be through the VPN. The port forwarding lets clients connect to you, so while it's not required, it's nice to have.

If you are on Window 7 or higher, you can launch PowerShell (Command Prompt won't do) and try the following:

First you need to know PIA's internal ip address:
Code:
ipconfig | select-string -pattern "10\."

should return a 10.x.x.x address. It should be the same IP address shown in the output in the VPN Helper for PIA window. If it isn't, then that's the problem

Then the following:

Code:
$wc = New-Object System.Net.WebClient
$result = $wc.UploadString("https://www.privateinternetaccess.com/vpninfo/port_forward_assignment", "user=<YourUserName>&pass=<YourPW>&client_id=12345678&local_ip=<IP from above>")
echo $result

Replace <YourUserName>, <YourPW> with your stuff, and <IP from above> with the 10.x.x.x address you got from ipconfig.

This should result in something like {"port":1112}, or an error message. This is the same URL the VPN helper uses to get the port address
Reply
#5
I've been having the same problem, and like the OP, it appeared to begin with the last Vuze update.

I was trying to work out what was going wrong just prior to finding this thread... and for what it's worth, I'm leaning rather heavily toward the problem being with the plugin itself. The plugin appears to have been updated at the same time as the Vuze update.

If I uninstall version 5.1 of the plugin and reinstall version 5.0, everything works happily again.

The problem I now face is that the plugin immediately updates itself to 5.1 and the problem reoccurs. Not sure what my next step should be, but if I can't find a fix, I'll be ditching the plugin.
Reply
#6
Photo 
I'm afraid I get nothing- it's hard to copy what is in the command window, but here's some of it:

Windows PowerShell
Copyright © 2009 Microsoft Corporation. All rights reserv

PS C:\Users\Denis> ipconfig | select-string -pattern "10\."
The term 'ipconfig' is not recognized as the name of a cmdlWindows PowerShell
Copyright © 2009 Microsoft Corporation. All rights reserv

PS C:\Users\Denis> ipconfig | select-string -pattern "10\."
The term 'ipconfig' is not recognized as the name of a cmdlet, function, script file or operable program. Check sp
elling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:9
+ ipconfig <<<<  | select-string -pattern "10\."
    + CategoryInfo          : ObjectNotFound: (ipconfig:Str
    + FullyQualifiedErrorId : CommandNotFoundException

There's more that didn't copy- but it seems clear that PowerShell doesn't want to know about my problems! :-) On most computer things I'm reasonably expert- I've built my own for decades- but I've never gotten much into shell commands & IP addresses, and have never used PowerShell before, so in this I'm a total novice. 

Further investigation shows weird things in my network connections, as shown here (see attachment.)

Anyway, my Network Connections window shows that my main Local Area Connection is unplugged (?), but my LAC #2 is connected, and LAC #3 goes to Team: Team #0 (?) and that an unidentified network is on LAC #5, which is connected to TAP- Windows Adapter V9; that last one at least sounds familiar. I'm in totally unfamiliar scenery here, and am getting confused. Now I'm suspecting that I have some unidentified problem with my network connections, and that this may not be anything to do with Vuze+.

And I still don't know why I can't get the ipconfig to work. I did find that PIA is working, I went to their website and it gives my IP address & tells me it's in Canada; which is as it should be (but I'm actually in California.) It also says that I am safe, as PIA is working. 

Does any of the above hold any clues as to what's going on? All I know right now is that MY head is spinning! :-(


Attached Files Thumbnail(s)
   
Reply
#7
oh no, no ipconfig! I guess maybe only Windows 7 Pro has it, or Administrators or something.

If you are connecting to peers (which it sounds like you are) while PIA is on, there's really not much to worry about. Having the port forwarding is an extra perk, and not required. You can always manually enter the port number into Vuze whenever PIA changes it.

Sorry I couldn't have been more help. I would have liked to known why it's not working for you, but I guess it will have to remain one of those mysteries.
Reply
#8
Yes, it's a mystery why I get no ipconfig- I'm running Win7 Ult. as an Administrator, too. Weird! One more thing to have me scratching my head.

I tend to agree with cwake that this problem is something not-quite-right in the updated VPN Helper plugin. Before the update, I never had a problem with that plugin; since then, I've had nothing but problems. I hope the update gets updated soon!

I am glad that it appears that I'm still connecting to peers through PIA, but I'd sure like to have a clean board, so to speak. I hate error indications!

(One unexpected bonus to this problem- aside from discovering this very useful and pleasant Forum, which has nice helpful people!- is that I contacted my ISP to ask them some questions, and found that I can get a 12-mo reduction in cost & higher download speed! So it was definitely worthwhile to come here, and it shows that some clouds have a silver lining!)

Thank you, ArronM for your great help, and thank you too cwake for confirming that it isn't just me having this problem! I'm learning a lot (and finding out there is still so very much I don't know; I've never had problems with this area of computing before, so there's a lot to learn.) Now I'll go back & poke around some more where angels fear to tread!
Reply
#9
OK, I found out why I couldn't get ipconfig: I didn't have a path to ipconfig.exe in my System Path Environment Variable (somehow it must've got lost, dunno how.) Now I've put that path back in, and ipconfig works! Hurray!

Well, maybe not hurray quite yet. :-(

After going through the procedure with the PowerShell that ArronM kindly furnished, I have come up with the following:
--PIA says that my port is 41771; Vuze Options/Connections has port 22380 listed; ArronM's procedure gives the result as port 44850. They're ALL DIFFERENT!

BTW, PIA's internal IP address on my machine is 10.83.10.6 "aka eth6 (TAP-Windows Adaptor V9)" and the entries go on to say that "Vuze is already bound to eth6" which is excellent- but it still can't get the forwarding port.
 
PIA is set to CA-Toronto (172.98.67.38) if that has any bearing on this problem. Also, I started Vuze but adjusted nothing before running the procedure. I tried setting the port in Options/Connections to 44850, but nothing changed; still "Couldn't get forwarding port." Then I tried changing that setting to 41771 and got the same lack of results. 

Does this mean anything in terms of how I can fix this? (Remember Linda Blair in The Exorcist? My head is spinning even faster!)
Reply
#10
All 3 different! Wow! The Vuze one is probably definitely maybe wrong. Potentially both PIA and the other one (44850) are correct. One of them is definitely correct, and it could be that you got a second port open with that command.

I have something new for you to try! Go into VPN Helper and remove the "Path to PIA Manager program". Save and click the Check Now button on the VPN Helper window. 10% chance it will give you a "Port returned from RPC is xxxx"

(03-10-2017, 03:51 PM)Eskyman Wrote: OK, I found out why I couldn't get ipconfig: I didn't have a path to ipconfig.exe in my System Path Environment Variable (somehow it must've got lost, dunno how.) Now I've put that path back in, and ipconfig works! Hurray!

Well, maybe not hurray quite yet. :-(

After going through the procedure with the PowerShell that ArronM kindly furnished, I have come up with the following:
--PIA says that my port is 41771; Vuze Options/Connections has port 22380 listed; ArronM's procedure gives the result as port 44850. They're ALL DIFFERENT!

BTW, PIA's internal IP address on my machine is 10.83.10.6 "aka eth6 (TAP-Windows Adaptor V9)" and the entries go on to say that "Vuze is already bound to eth6" which is excellent- but it still can't get the forwarding port.
 
PIA is set to CA-Toronto (172.98.67.38) if that has any bearing on this problem. Also, I started Vuze but adjusted nothing before running the procedure. I tried setting the port in Options/Connections to 44850, but nothing changed; still "Couldn't get forwarding port." Then I tried changing that setting to 41771 and got the same lack of results. 

Does this mean anything in terms of how I can fix this? (Remember Linda Blair in The Exorcist? My head is spinning even faster!)
Reply
#11
***SUCCESS!!!*** That did it, ArronM! 

That sure seemed like something I've already tried, but why not give it another shot- so I deleted the path as you suggested, saved, and then clicked on Check Now; and as I hopelessly expected, nothing happened. Oh well... but then why not restart Vuze, to see if that made any difference?

I restarted; VPN Helper still gave the familiar error, and when I looked at Config I found that my login & pass were now blank as well. 

So then I used the Browse button to find the PIA Manager in Program Files, & put my PIA login & password back in (for the 4,357th time, it seemed) and saved. Back to the VPN Helper window, and without much hope clicked on the "Check Now" button....

Lo and Behold! This time it worked! It said "Port Returned from RPC is 41771." The VPN Helper for PIA status is now OK! The port that PIA indicates is the same port that Vuze indicates! Every line has the checkmark that says it's OK! Whoo-hoo!
 
So your advice was spot-on, and all I can add to it is "restart Vuze after saving." 

Now I can really say, "Hooray!" and thank you ArronM!!! 

Y'know- before this error happened, I had: slower, more expensive internet service; a missing Path Variable that I didn't even know about; and a very useful Vuze Forum that I also didn't know about. So now I feel on top of the world, and I've gained a lot of knowledge too!

Thanks again, and I think this thread can now be marked, "Case Closed- Successfully!" 

(And as The Terminator famously said, "I'll be back"- to this Forum again!)
Reply
#12
I can confirm that Eskyman has described a functional workaround!!
I suspect that many other users in the same boat will be very thankful for your documenting your success.

The key steps seem to be removing the old PIA data, restarting Vuze, and then re-entering the PIA data as though you were using the plugin for the first time. Presumably a bug in 5.1, but I expect that it won't happen in 5.2 now should it be updated again. ;-)

Well done ArronM and Eskyman, and thank you.
Reply
#13
Im having the same issue but i use air vpn

VPN HAS WARNINGS
✔ Vuze UDP is currently bound to /10.4.65.123 aka eth4 (TAP-Windows Adapter V9)
✔ Found bindable address /10.4.65.123 on eth4 (TAP-Windows Adapter V9) which is likely VPN's local IP
✔ Non-Vuze probably routing through /10.4.65.123 aka eth4 (TAP-Windows Adapter V9). Same as bindable address :)
✔ Excellent, Vuze already bound to eth4
⌘ Could not get auth_key from AirVPN's Login page
⌘ Could not get Forwarding Port.  Ensure PIA Manager directory is properly set, or set user/pass in plugin config.

Wont work since update can anyone help  thank you
Reply
#14
Hi everyone,

I have been having a problem over the past few days with VUZE/VPN Helper, with status staying 'BAD'.

I have updated Vuze to :-

Java 1.8.0_66 (64 bit)

 Oracle Corporation
c:\program files\vuze\jre

SWT v4716, win32
Windows 7 v6.1, amd64
V5.7.5.0/4 az3.

This made no difference.

I uninstalled PIA manager and installed the latest version yet I still see this message :-


VPN NOT SET UP CORRECTLY
✔ Vuze UDP is currently bound to /10.77.10.6 aka eth6 (TAP-Windows Adapter V9)
⌘ Can't reach PIA's site using /10.77.10.6 aka eth6 (TAP-Windows Adapter V9)
⌘ Can't reach PIA's site using /10.77.10.6 aka eth6 (TAP-Windows Adapter V9)

Non-Vuze probably routing through /10.77.10.6 aka eth6 (TAP-Windows Adapter V9).
X Can't determine VPN's local IP
⌘ Keeping existing binding of eth6

Vuze works, NAT / Firewall test... is successful, so how can I return the VPN Helper status to 'OK' ???

Many thanks!
Reply
#15
Looks like AirVPN changed things on their website which prevented the plugin from accessing it. We've just released a new plugin (5.2) which will fix this. Please note, you were still securely using AirVPN, it was just that the plugin couldn't access AirVPN to open a port.


(03-20-2017, 02:35 PM)james666 Wrote: Im having the same issue but i use air vpn

VPN HAS WARNINGS
✔ Vuze UDP is currently bound to /10.4.65.123 aka eth4 (TAP-Windows Adapter V9)
✔ Found bindable address /10.4.65.123 on eth4 (TAP-Windows Adapter V9) which is likely VPN's local IP
✔ Non-Vuze probably routing through /10.4.65.123 aka eth4 (TAP-Windows Adapter V9). Same as bindable address :)
✔ Excellent, Vuze already bound to eth4
⌘ Could not get auth_key from AirVPN's Login page
⌘ Could not get Forwarding Port.  Ensure PIA Manager directory is properly set, or set user/pass in plugin config.

Wont work since update can anyone help  thank you
Reply
#16
(03-22-2017, 01:15 PM)'ArronM' Wrote: Looks like AirVPN changed things on their website which prevented the plugin from accessing it. We've just released a new plugin (5.2) which will fix this. Please note, you were still securely using AirVPN, it was just that the plugin couldn't access AirVPN to open a port.


(03-20-2017, 02:35 PM)'james666' Wrote: Im having the same issue but i use air vpn

VPN HAS WARNINGS
✔ Vuze UDP is currently bound to /10.4.65.123 aka eth4 (TAP-Windows Adapter V9)
✔ Found bindable address /10.4.65.123 on eth4 (TAP-Windows Adapter V9) which is likely VPN's local IP
✔ Non-Vuze probably routing through /10.4.65.123 aka eth4 (TAP-Windows Adapter V9). Same as bindable address :)
✔ Excellent, Vuze already bound to eth4
⌘ Could not get auth_key from AirVPN's Login page
⌘ Could not get Forwarding Port.  Ensure PIA Manager directory is properly set, or set user/pass in plugin config.

Wont work since update can anyone help  thank you

 

Hi ArronM,

I have updated to VPN Helper V5.2, unfortunately, it has not helped :(

[22:48:58] ✔ Vuze UDP is currently bound to /10.22.10.6 aka eth6 (TAP-Windows Adapter V9)
[22:49:01] ⌘ Can't reach PIA's site using /10.22.10.6 aka eth6 (TAP-Windows Adapter V9)
[22:49:01] subnet: 30; Score: 1
[22:49:01] ⌘ Can't reach PIA's site using /10.22.10.6 aka eth6 (TAP-Windows Adapter V9)
[22:49:01] Non-Vuze probably routing through /10.22.10.6 aka eth6 (TAP-Windows Adapter V9).
[22:49:01] ✖ Can't determine VPN's local IP
[22:49:01] ⌘ Keeping existing binding of eth6


I am not using AirVPN, I am using PIA. Hope this helps.

Many thanks.

G
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
Question Testing TCP port 61351 inbound VuzeDude 2 5,662 10-13-2018, 03:59 AM
Last Post: VuzeDude
  VPN (PIA) showing different Port to Vuze? BigBad64 0 1,898 03-25-2018, 01:37 PM
Last Post: BigBad64



Users browsing this thread: 1 Guest(s)