Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No Route To Host
I am attempting to set up an RSS feed between two servers running RHEL 6.5. S1 is serving as the host and has the torrents that are in the RSS feed. S2 is the client trying to download the torrents throught the RSS feed. On S2 I get the error  

I/O Exception while downloading '' , No route to host

I can ping between the two servers so I know they are reachable. I have also allowed all the ports necessary on my iptables file on both servers. 

-A INPUT -p tcp --dport 56742 -j ACCEPT
-A INPUT -p udp --dport 56742 -j ACCEPT
-A INPUT -p tcp --dport 6889 -j ACCEPT
-A INPUT -p udp --dport 6889 -j ACCEPT
-A INPUT -p tcp --dport 6969 -j ACCEPT
-A INPUT -p udp --dport 6969 -j ACCEPT

Yet I still get the same 'No route to host' error. I'm not sure what else to try. Thanks in advance for the help. 
Can you browse to (or use wget to download) the feed on S1 via ?

How about on S1 via the 192 address?

Likewise from S2 using a browser/wget via the 192 address

Just trying to rule out Vuze being involved in the issue...
Yes wget worked for all the tests you suggested
scratches head.... what are you using in Vuze to download the feed - a subscription you created? A plugin such as the 'RSS Feed' plugin? I can't think what would be causing that error from within Vuze when it works fine from a shell on the same machine.
Yes I used 'RSS Feed' plugin to create a feed for my torrents on S1. When I try to connect to that feed from S2 to download the torrents it shows the error 'I/O Exception while downloading '' , No route to host'. I thought it may be a firewall issue so i tried adding the ports to the iptable and also tried turning it off all together and both did not work. This is all being done in the console UI with no access to the gui side. 
Hmm, the 'RSS Feed' plugin ( doesn't generate a feed, it downloads a feed - are you using something else to create the RSS feed? Not that I guess this matters if you have a feed being generated!

The only other things within Vuze that might cause this would be if you had configured a SOCKS server or explicitly bound Vuze to an interface such as loopback/

Beyond that I have no idea.
I have not configured a SOCKS nor have I explicitly bounded Vuze.I am using the azrssgen ( plugin that creates a feed out of a category assigned to a torrent. It is installed in S1. I manually add the RSS feed to S2 by using 'subs create'. I have gotten past the 'no route to host' issue for the time being but have ran into another one. When S2 tries to download the torrent from the RSS feed from S1 it gets stuck at 
Metadata download for magnet:H6YH6XZOQPJJZDXWNP32DJQYDUVFLCQT.torrent

and no progress is ever made. So i tried scp the torrent file from S1 to S2 and adding it manually to download on S2 and the following error show in the status bar when i run 'show 1' 
Status: Connection Error (IOException: Server returned HTTP response code: 400 for URL:*U%8A%13&peer_id=-AZ5501-V8oHkczwNUVO&supportcrypto=1&port=21713&azudp=21713&uploaded=0&downloaded=0&left=3853516800&corrupt=0&event=started&numwant=100&no_peer_id=1&compact=1&key=U5L1WPKl&azver=3)

the status never makes any progress and stays at 0%, but when I go to my download directory the .iso file is there. When I hop back onto Vuze the status is still at 0% and the error message persists. All the torrents I am using I create myself in Vuze and use the built in tracker function for the torrent i.e My best guess is that i need to disable DHT in the setting in the console but am not sure how. Please let me know any other things i should try. thanks  
The 'azrssgen' plugin uses magnet links for all downloads in the feeds that it generates - this means that the DHT has to be operating properly on both the server and client Vuze instances in order for the torrent to download - particularly if these are your own downloads which mean there's no other peers that you can get the torrent files from.

As for the HTTP 400 error, that again is a pretty weird one - not even sure that the built in tracker can return that code... what does wget do with that URL?

If all you are trying to do is mirror torrents from one Vuze instance running the tracker and seeding torrents to another one then you might have more luck using the RSS feed generated by the tracker-web-pages plugin  ( as this feed contains http links for the torrents rather than magnet links.
This is what wget returns

--2014-12-03 04:53:41--
Connecting to connected.
HTTP request sent, awaiting response... 400 Bad Request
2014-12-03 04:53:41 ERROR 400: Bad Request.

How would I check to see if DHT is running properly or set it up? My firewalls are down on both servers so what are other things i should check to allow the DHT to work properly and the magnet link from the RSS feed to download.
I looked in UPnP_1.log and see 

Mapping request: Incoming Peer Data Port (UDP/21713), enabled = true
[9:50:32] Mapping request: UDP Tracker Client Port (UDP/21713), enabled = true
[9:50:32] Mapping request: Incoming Peer Data Port (TCP/21713), enabled = true
[9:50:32] Mapping request: Incoming Peer Data Port (TCP/8080), enabled = false
[9:50:32] Mapping request: TCP Tracker Port (TCP/6969), enabled = false
[9:50:32] Mapping request: TCP SSL Tracker Port (TCP/7000), enabled = false
[9:50:32] Mapping request: UDP Tracker Port (UDP/6969), enabled = false
[9:50:32] Mapping request: RSS Feed Generator (TCP/6889), enabled = true
[9:50:32] Mapping request: Distributed DB (UDP/21713), enabled = true

I assuming the because of the 4 ports with false values I am having trouble with my DHT?

As for the tracker-web-page plugin i don't have access to a browser and everything is being done strictly in the RHEL 6.5 terminal. So how would I be able to use the tracker-web-page plugin? 
As always thanks for all your help parg. 


Users browsing this thread: 1 Guest(s)