Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New router - NAT/Port Forwarding issue
#1
Hey there, wanted to see if anyone out there could shed any light on this problem i'm having with Vuze related to a new router.  I've been using Vuze for a couple of years now and recently my router died and i replaced it, everything else is working fine internet access-wise, i can upload and download just fine.  However, all of my torrents which had been running fine are now sitting in a "blue" status (as opposed to green, yellow or red) and my torrents seem to be running fine, but no one is connecting with them, except in a VERY few cases.  Essentially, i was/am running about 80 torrents and no one from the outside seems to be able to connect with me.  I can download a torrent just fine, but i'm unable to share what i've snatched.

To attempt to isolate the issue, i've used the two tools that i know of that Vuze provides. The first is under Help->Network Status where i can test my connection.  A couple of errors pop up (the 'xx' in the port number is on purpose, the port number is an actual number):

Testing TCP port 104xx inbound
    Test failed: NAT test failed: Error: Connection refused: connect
    Check your port forwarding for TCP 104xx
and
Testing UDP port 104xx inbound
    Sending outbound packet and waiting for reply probe (timeout=5000)
    Sending outbound packet and waiting for reply probe (timeout=10000)
    Sending outbound packet and waiting for reply probe (timeout=15000)
    Sending completion event
    Test failed: Inbound test failed
    Check your port forwarding for UDP 104xx
 No incoming connections received, likely NAT problems

The second test that i did was under Help->NAT Firewall Test.  The dialog box comes up and the Incoming TCP Listen Port is populated with the port that i'd set up in the Preferences.  When running that test, i get:
Testing port TCP 104xx ...
Unable to test: Invalid port given, or test service failed.
Another application may already be using this port..
(Error: Connection refused: connect).

I get something similar for the UDP port test:

Testing port UDP 104xx ...
    Sending outbound packet and waiting for reply probe (timeout=5000)
    Sending outbound packet and waiting for reply probe (timeout=10000)
    Sending outbound packet and waiting for reply probe (timeout=15000)
    Sending completion event
NAT Error. Inbound test failed, timed out.

The first test seems to indicate that the port may be in use.  Well, it SHOULD be - by Vuze!  So that message is confusing, but might actually point to the real problem.

I've got potentially three firewalls on my machine, Norton, a firewall on my router and the Windows Firewall.  I'd long ago configured Norton to be my primary firewall, so that the Windows firewall defers to it.  I've disabled the firewall on my new router.  Same results.  I've also tested disabling ALL of my firewalls.  Same result!

After receiving the above results, i've dove into port forwarding and setting up a static IP behind my firewall.  I'll dive into the details of that in a followup post if necessary.  The long and the short of it is that the above results hold even when i've set up port forwarding.  For the moment, i'm wondering aloud if anyone sees anything obvious that i might be missing before i dive into trying to describe all of that?

cheers and thanks for reading!
Reply
#2
A little more information and a question.

First, there is no VPN involved here at all.  This is just Vuze running on a Windows 10 pc, using the latest version.

Second, a couple of torrents that i am sharing HAVE connected with a seeder or two.  However, i've got torrents running that have hundreds of seeds and should be fairly active and my connections are quite rare.  In the couple of instances that i have connected with a peer, the status of the torrent has actually changed from blue to YELLOW, which seems quite odd.

Finally, as i understand it, for Vuze to work properly setting up a static IP address behind your firewall is REQUIRED for Vuze to work properly, is it not?  I don't remember setting that up with my last router, but that was a couple of years ago and i may have forgotten.  I've found a variety of sources that suggest that it is.  Including this one:

https://blog.vuze.com/2014/01/22/vuze-10...port-vuze/

I can give details on what i did in the port forwarding area, but what i did was fairly straightforward.  I actually called ASUS (the maker of my router) to get their help.  I don't think their technical support is up to the task.  The guy i talked to deferred and said he'd refer my question to his team and someone would get back to be in 24-48 hours.  It's been 72 and i'm no longer holding my breath.  Since a bunch of people here would necessarily need to have done this, i'm hoping someone encountered and resolved this issue as well.

thanks!
Reply
#3
Lots of people READING this thread, but no one is WRITING.....

OK, on the port forwarding, here is what i've done:

I'm on a PC using Windows 10 -
1.  Control Panel->Network and Internet->Network and Sharing Center->Change Adapter Settings
2.  Chose My Local Area Network
3.  Properties->Internet Protocol Version 4 (TCP/IPv4)->Properties
4.  Modified "Obtain and IP Address Automatically" to "Use the Following IP Address".
5.  Created these values (NOT the actual values for security purposes).  Where the numbers match, that indicates that i used the same value in both places .....

a.  IP Address: 192.55.2.2 (this is the static IP that i created manually)
b. Subnet Mask: 255.255.255.0
c.  Default Gateway:  192.55.2.1 (this is the value obtained from running "ipconfig/all" from the command shell)

6.  Changed from 'Obtain DNS server automatically' to 'Use the following DNS server addresses'.

a.  Under "Preferred DNS Server", i used the same value as in 5c above (default gateway).

That's it for Windows.  Then, i went into my ASUS router software (RT-AC1200) and....
1.  Went into the Firewall section and disabled the firewall.
2.  Went into the WAN section and went to the Virtual Server/Port Forwarding tab and created a port forwarding entry containing the following values

a.  Service Name:  Vuze
b.  Port Range:  104xx (port specified within Vuze under Tools->Options->Connection->Incoming TCP listen port and UDP listen port - they are the same, just as before)
c.  Local IP:  the new static IP address that i created above - 192.55.2.2 
d.  Protocol: Both (Meaning both TCP and UDP)

That's it, created the entry with that data.  Obviously, if you don't have my router, what you would have done in your router software would be different, but you could probably still tell if a value that i used was not the right one.  At least, that is what i am HOPING!  :-)

That's all the info that i can provide, suggestions welcome!
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Java 9 issue, failing to load, +Firefox magnet link setup failing Melchior 3 7,266 03-13-2018, 06:50 AM
Last Post: Melchior
  Adding a torrents and choosing of Save location issue KonradK 1 1,907 12-19-2017, 12:28 AM
Last Post: ekstasee



Users browsing this thread: 1 Guest(s)