Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(Mostly-)SOLVED: RSSFeed Scanner plugin hanging (forever) at "Connecting"
It appears that the RSSFeed Scanner plugin has developed a problem accessing some of my feeds (three, all from the same site), and hanging indefinitely on the attempt in a way that blocks it processing the rest of my feeds (two, from two different sites).

First, relevant environment: Vuze running on Fedora Linux 25 x86_64

Java 1.8.0_121 (64 bit)
Oracle Corporation

SWT v4628, gtk/2.24.31
Linux v4.10.6-200.fc25.x86_64, amd64
V5.7.5.0/4 az2
RSSFeed Scanner plugin version 1.5.3

If I leave the plugin processing the two "good" feeds, everything is fine and it updates normally. However, I had to configure the set of feeds from a third site to Disabled, because attempting to process one of them will lock up the plugin completely, preventing it from processing any of the feeds. Restarting Vuze appears to be the only way to recover when that happens.

A brief walkthrough of what happens:
  1. Initial state, RSSFeed Scanner is running normally
  2. I right-click on a "bad" feed and select "Refresh Feed" (or its reload timer expires, if it's Enabled)
  3. The "Status/Link" column changes to "Connecting" and gets stuck there
  4. The "Connecting" status prevents any other feeds (even the "good" ones) from refreshing; if a reload is attempted, the "Status/Link" column changes to "Pending" and gets stuck there
  5. All feed processing hangs waiting for the "Connecting" status to clear, which it never will (until a Vuze restart)
I'm pretty sure that the following message is logged to the Console when the "bad" feed attempts to refresh and gets stuck in "Connecting" mode; it's the only indication I could see in the logs of what's going on, and RSSFeed Scanner reports no logging or status of its own (other than "Connecting").

[17:34:46.143] {stderr} ........................................................................................................................................
DEBUG::Mon Apr 10 17:34:46 EDT 2017::org.gudy.azureus2.core3.util.DebugLight::printStackTrace::35:
[17:34:46.144] {stderr} java.lang.NullPointerException
[17:34:46.144] {stderr} at org.gudy.azureus2.ui.swt.auth.AuthenticatorWindow$authDialog.<init>;(
[17:34:46.144] {stderr} at org.gudy.azureus2.ui.swt.auth.AuthenticatorWindow$1.runSupport(
[17:34:46.144] {stderr} at
[17:34:46.145] {stderr} at
[17:34:46.145] {stderr} at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(
[17:34:46.145] {stderr} at org.eclipse.swt.widgets.Display.runAsyncMessages(
[17:34:46.145] {stderr} at org.eclipse.swt.widgets.Display.readAndDispatch(
[17:34:46.145] {stderr} at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>;(
[17:34:46.145] {stderr} at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(
[17:34:46.145] {stderr} at com.aelitis.azureus.ui.swt.Initializer.<init>;(
[17:34:46.145] {stderr} at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
[17:34:46.145] {stderr} at sun.reflect.NativeConstructorAccessorImpl.newInstance(
[17:34:46.145] {stderr} at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
[17:34:46.145] {stderr} at java.lang.reflect.Constructor.newInstance(
[17:34:46.146] {stderr} at org.gudy.azureus2.ui.swt.Main.<init>;(
[17:34:46.146] {stderr} at org.gudy.azureus2.ui.swt.Main.main(
[17:34:46.146] {stderr} at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[17:34:46.146] {stderr} at sun.reflect.NativeMethodAccessorImpl.invoke(
[17:34:46.146] {stderr} at sun.reflect.DelegatingMethodAccessorImpl.invoke(
[17:34:46.146] {stderr} at java.lang.reflect.Method.invoke(
[17:34:46.146] {stderr} at com.aelitis.azureus.launcher.MainExecutor$
[17:34:46.146] {stderr} at
[17:34:46.146] {stderr}
(I inserted a newline before "DEBUG::" to make it wrap better for readability.)
So I gather it's attempting to display some sort of authentication window?

The "bad" feeds in question were originally http:// URLs that were being redirected to https:// (the site serving them went HTTPS-everywhere). I edited the config to use the https:// URLs directly, but that didn't make any difference. Of my two "good" feeds, one is HTTP and the other is HTTPS, so I know that the plugin can load HTTPS feeds. It's just failing to, apparently, from this one site.
Try 5751_B10 when it appears - thanks!
I will, thanks!

I was actually going to reply "never mind", as I managed to work around this.

Basically, the site was requesting Authentication, as discovered when I attempted to load a feed URL in Firefox on that machine. (I'd tried it on my local machine, which isn't the one running Vuze, and I didn't get an authentication prompt here because I was already logged in to the site in this browser.)

So, by transferring the session cookies into the plugin configs, I got the feeds un-stuck. Kind of a pain, though, because if Vuze had actually showed me the authentication dialog I could've entered my login credentials and gotten in. Other methods of passing the login info that were recommended in the site forums, such as using https://username:password@site/path.xml URLs, weren't successful with the plugin.
Thumbs Up 
parg\ dateline='\'1491864449' Wrote: Try 5751_B10 when it appears - thanks!

I beta-updated to 5751_B10 just now, and after turning off the cookie-passing options in the RSSFeed configs and triggering a feed refresh, "Connecting" was immediately followed by an authentication dialog popup. After entering my credentials and checking "Remember Password", the refresh completed and the feed list loaded as expected.

So, yep, fixed in 5751_B10. Thanks!
So, as a followup to this, I seem to have created a little problem for myself.

Some of the needs-auth sites are working now, but for (at least?) one the connections are failing and I'm getting the following message in the logs at every attempt:

Authentication for _SERVER_/https://_SERVER_:443// ignored as told not to ask again

It appears that, at some point in my fiddling around, I checked the "Do not ask this again" box in the site's auth dialog. And I can't seem to find any way to undo that, so that I can actually authenticate to the server!

(06-11-2017, 02:02 PM)'FeRDNYC' Wrote: It appears that, at some point in my fiddling around, I checked the "Do not ask this again" box in the site's auth dialog. And I can't seem to find any way to undo that, so that I can actually authenticate to the server!

I ended up working around this by simply re-enabling the manual cookie passing that I'd previously set up to work around the crashing authentication box. Which works just fine, in terms of getting Vuze pulling results from the RSS feeds in question. But it's still kind of a bummer that I'm not using the built-in authentication capability, now that it's fixed, simply because I can't find a way to UN-disable the authentication dialog for that particular site.

I'm not sure I really understand why that "Do not ask again" box would be there, with no mechanism for reversing the decision, rather than a pattern which uses a "Remember login" checkbox to store the authentication data, but could still pop up the dialog should the stored credentials stop working. Seems an odd decision by Sun/Oracle. (I'm assuming the dialog in question is part of the built-in Java authentication support.)

Possibly Related Threads...
Thread Author Replies Views Last Post
  Auto-Shutdown Plugin? BigBad64 2 6,932 03-26-2018, 02:17 PM
Last Post: Havokdan
  VUZE - enable plugin bar. joliett 4 7,983 12-19-2017, 01:38 AM
Last Post: joliett

Users browsing this thread: 1 Guest(s)