Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kickass Not Working
Hi, i am new to this,i have been using Kickass for ages, for about the last week nothing has shown up? Can any one help?
Thanks in Advance
Hi... I am having a similar problem today.
I have managed to download a couple of files this morning but suddenly noticed this afternoon that Kickass is not showing a green tick and the wording is muted which would indicate it's not working on Vuze.
I made a HUGE mistake by trying to locate the torrent I wanted via Google and got onto the Kickass site (I think!) and tried to manually download and managed instead to give myself a headache and a heap of troubles with all the nasty stuff and strange programs which suddenly appeared on my PC.
I kept uninstalling and deleting all this crap only to have it come straight back as soon as I tried to open my browser.
Only by downloading a Malware trial have I got rid of it all. (think I'll swallow the cost and sign up for a proper copy)
And I now remember reading somewhere when I was searching on Google that Kickass has been moved and what you now get is a mountain of grief.
I can only hope it's just 'down' for the moment and not completely lost and gone forever.
Otherwise I guess my downloading torrent days are at an end unless some of the others take over the torrents Kickass supported.
I'd be very interested to hear from anyone who knows what's up with Kickass at present.
So many topics about this...
Try the latest beta - B22 (see
(10-01-2015, 06:44 AM)'parg' Wrote: Try the latest beta - B22 (see

I've been having the same problem with the KAT templates and the suggestion from parg worked perfectly for me!
I tried switching to the Beta program and that didn't work for me.  In addition, now my Extratorrent (the only one that was working before) isn't working anymore.  I'm on a Mac.  Can someone please give me basic, step-by-step instructions on what I can do to fix this?  Now I can't download anything anymore.

EDITED:  Okay, so I deleted the Vuze folder, reinstalled and restored my configuration.  My Extratorrent template is now working again but Kickass is still not.  Any other suggestions?
KAT and YTS is officially dead now.
KAT works for me.
I am having a problem with Kickass as well.  What's the simplest step to get it working again?
Kickass template from still works for me

Possibly Related Threads...
Thread Author Replies Views Last Post
  Downloads not startind due to ecurity certification not being found odingraphics 17 23,639 10-31-2016, 04:17 PM
Last Post: parg
  Meta Search Not Working With V5.7.1.0/4 woodduck80 1 4,247 08-29-2016, 12:55 PM
Last Post: drstina

Users browsing this thread: 1 Guest(s)