Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to use full bandwidth for seeding
Hello there!

I really like the Vuze Torrent Desktop Client even since it was Azureus.

I seed a lot of my torrents in 2 different computers located at different ISPs. The problem is, that at my home, my internet is supposedly 1 Megabit/s (~128 KB/s) for upload at the speedtests (OOKLA to be specific), but the sum of all bandwidth shown at the lower right corner of vuze main window shows that it uploads at 250 KB/s , which is far more than my bandwidth is, according to the speedtests, in this case, I am extremely happy :) .

On the other hand, the computer at my work, running the same speedtest shows that it has 80 Megabits/s (~10240 KB/s), but the sum of all torrents uploading is shown to between 500 KB/s and 1100 KB/s, even though I have tried to seed at my work's PC a torrent that I download at my home, and making sure that both of them are currently connected and transfering stuff, usually in this case the connections aren't above 500 KB/s. BUT when I use a different protocol for transfering files (like FTP, SSH or even using a chat program) the transfer uses the full bandwidth possible (in the case of home and work computers, it goes at 2500 KB/s which is the download limit for my home's internet), but in some other cases, the transfer between my work's PC (which is the uploader) and another PC goes even at 9500 KB/s or sometimes higher.

So, my question is: if I can use the full bandwidth with other methods of sharing files, why is it so slow on torrent seeding? (even using the very same computers for both cases); is there a way I can fix this? I have tried modifying the settings inside Vuze, at the Options>Transfers.

I don't use auto-speed on both my computers, and they have pretty much the very same settings, and my work's computer does not have NAT problems, but ironically my home's does and still it uploads at full speed while my work's doesn't...

Thanks in advance
Peers request data from you, not the other way around, so if there are lots of seeds in a swarm and not so many leechers then it is often the case that you can't max-out a large upload bandwidth.

YOu could try increasing the number of 'upload slots' per torrent (Tools>OPtions>Transfer) as you will only upload to this number of peers per torrent concurrently.

Don;t use auto-speed - set your upload limit at 80% of what your theoretical upload limit is.
It is also possible that your work somehow shapes torrent traffic.  Many many workplaces do that.

@parg So basically, if there is only 1 seeder and 1 leecher should the upload speed go near the bandwidth limit (or the upload limit set in the "Transfer" section)?

@GaryE Is there a way I can modify this behaviour? Because there was a time when torrents went up to 4 or 5 MB/s and it was Ok, and the ISP as I know has not been modified at all (My Workplace is an University with its own ISP), what I mean, is that if I can modify the Protocol as with the TCP/IP to check if the settings for upload speed are correct, and if not, modify them.
The upload speed will be limited by the minimum of 

* your available upload bandwidth
* the other peer's download bandwidth

Of course if the other peer has, say, 100KB/sec download bandwidth and is currently downloading from 9 other peers at 10KB/sec each, he'll only likely download from you at 10KB/sec.
I've been testing a little, and I am beginning to think that GaryE maybe is right: The ISP uses different speeds for torrent transfer and for FTP transfers; even though the Bandwidth is high for torrents it becomes like 10% of it...

And yeah, i knew that rule of limitation.... but somehow I feel that the problem is not that.

That is sad, because if it's the ISP fault (and not Vuze's fault), then there is a little I can do to share my stuff via torrent with full bandwidth speed... :(

Possibly Related Threads...
Thread Author Replies Views Last Post
  Particular RSS Feed won't download unless I delete torrent and use magnet PierceBangley 2 4,234 02-04-2017, 02:49 AM
Last Post: PierceBangley
  Error: Offline - Transport unavailable, Address already in use: Cannot bind Sharenova 0 5,094 01-20-2017, 07:07 AM
Last Post: Sharenova

Users browsing this thread: 1 Guest(s)