Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DEBUG messages
#1
I typically run Vuze from the console.  

 java -Dazureus.config.path=/Users/username/Library/Application\ Support/Vuze -jar Azureus2.jar --ui=console
Recently vuze has started generating DEBUG message every 1/2 hour. 

DEBUG::Sat Oct 25 19:48:33 CDT 2014  Executing OSAScript: 
DEBUG::Sat Oct 25 19:48:33 CDT 2014     tell application "System Events" to get the name of every login item
DEBUG::Sat Oct 25 19:48:35 CDT 2014  OSAScript Output: 
DEBUG::Sat Oct 25 19:48:35 CDT 2014  OSAScript Error (if any): null
DEBUG::Sat Oct 25 19:48:35 CDT 2014  OSAScript execution ended (1889ms)

I suppose they are harmless, but they are annoying.  Is there a way to turn the OSAScript off?

I also get this message on startup
Update available for 'Core Patch Checker', new version =
Apply these updates with the 'plugin update' command

But if I run plugin update nothing happens.

This is less annoying (and I hope harmless), since it only appears at start-up.
The OSAScript message comes every 1/2 hour.

And while I run using screen, so I don't see the messages all the time, when 
I do look (screen -r), the page is filled with them.

Thanks for any help.


 

 
Reply
#2
The OSA debugs will be removed next beta

Not sure about the plugin update message, I'll take a look if I get a chance
Reply
#3
Thanks, would that be the Azureus5401-B29.jar that I should watch for?
Reply
#4
Yup, I'll do it later today
Reply
#5
I tried using using B29 but now I get:

Update available for 'Platform-specific support', new version = 1.11
Normally installed via auto-update.
This plugin contains platform-specific support for Azureus. For windows this includes file association support and Azureus.exe.
To manually install this plugin, unzip the files into the Azureus program location, ensuring that the OS-specific path within the ZIP file is removed.
1.11: file association/uri scheme support.
1.10: Attempt to fix rare startup error.
1.09: Added better USB device detection.
1.08: Fixed magnet URL handling.
1.07: Fixed 10.5 menu problem.
1.06: Unified jnilib.
1.05: Remove debug.
1.04: Initial release.

DEBUG::Sun Oct 26 18:21:51 CDT 2014::org.gudy.azureus2.pluginsimpl.local.utils.resourcedownloader.ResourceDownloaderBaseImpl::informFailed::445:
[http://cf1.vuze.com/torrent/torrents/azplatform2-osx_1.11.zip.torrent: torrent,http://plugins.vuze.com/plugins/azplatform2-osx_1.11.zip] failed
cancel (org.gudy.azureus2.pluginsimpl.local.utils.resourcedownloader.ResourceDownloaderAlternateImpl.java:278), cancel (org.gudy.azureus2.pluginsimpl.local.update.UpdateImpl.java:202), cancel (org.gudy.azureus2.pluginsimpl.local.update.UpdateCheckInstanceImpl.java:566), complete (org.gudy.azureus2.ui.console.ConsoleInput$5.java:802), run (org.gudy.azureus2.pluginsimpl.local.update.UpdateCheckInstanceImpl$4.java:456), run (org.gudy.azureus2.core3.util.AEThread2$threadWrapper.java:294)
org.gudy.azureus2.plugins.utils.resourcedownloader.ResourceDownloaderCancelledException: [http://cf1.vuze.com/torrent/torrents/azplatform2-osx_1.11.zip.torrent: torrent,http://plugins.vuze.com/plugins/azplatform2-osx_1.11.zip]: Download cancelled
at org.gudy.azureus2.pluginsimpl.local.utils.resourcedownloader.ResourceDownloaderAlternateImpl.cancel(ResourceDownloaderAlternateImpl.java:274)
at org.gudy.azureus2.pluginsimpl.local.update.UpdateImpl.cancel(UpdateImpl.java:202)
at org.gudy.azureus2.pluginsimpl.local.update.UpdateCheckInstanceImpl.cancel(UpdateCheckInstanceImpl.java:566)
at org.gudy.azureus2.ui.console.ConsoleInput$5.complete(ConsoleInput.java:802)
at org.gudy.azureus2.pluginsimpl.local.update.UpdateCheckInstanceImpl$4.run(UpdateCheckInstanceImpl.java:456)
at org.gudy.azureus2.core3.util.AEThread2$threadWrapper.run(AEThread2.java:294)
Apply these updates with the 'plugin update' command


So I ran plugin update

plugin update
Updating Platform-specific support
Downloading: [http://cf1.vuze.com/torrent/torrents/azplatform2-osx_1.11.zip.torrent: torrent,http://plugins.vuze.com/plugins/azplatform2-osx_1.11.zip]
Downloading: azplatform2-osx_1.11.zip
Torrent download complete
100%
Data verified successfully
Adding update action for 'Contents/Resources/Java/dll/libOSXAccess.jnilib'
Adding update action for 'Contents/Resources/Java/dll/libOSXAccess_10.5.jnilib'
**** Restart required to complete update ****

then I restarted, but I get the same messages each time.

Something seems wrong,
do you know what I should do now?
Reply
#6
Unfortunately some of the 'core' plugin updates like this don't install correctly when running from the command line - best fix is for you to manually replace those files (the jnilibs) when Vuze isn't running

http://plugins.vuze.com/plugins/azplatform2-osx_1.11.zip


contains them
Reply
#7
I should add that the two files:
libOSXAccess.jnilib
libOSXAccess_10.5.jnilib

were always there, so I don't know why its trying grab them.

Thanks for your help.
Reply
#8
Have these files changed?  (I didn't see your reply when I wrote my last message).

When I download them fresh, they carry an Aug. 2013 date, so it would appear they are the same as the files I always had.

Could it be the azureus.sig file that should go somewhere?
But that is also dated 2013

EDIT:
Ignore this message and see the next one.
Reply
#9
Well as usual you are right.

These two files are actually in multiple places.
/Applications/Vuze.app/Contents
and in
/Applications/Vuze.app/Contents/Resources/Java/dll
and in
/Applications/Vuze.app/Contents/Azureus.app/Contents/Resources/Java/dll

The latter two were current, but the files in the upper directory were actually different.

When I replaced those, the pesky messages are gone.
I don't know why it never complained before B29, but it seems things are working (they probably
were always working), without warnings.

Well there's still that primaryclassloader
and
DEBUG::Sun Oct 26 19:40:09 CDT 2014 Select operation looks broken, trying workaround
DEBUG::Sun Oct 26 19:40:09 CDT 2014 Select operation looks broken, trying workaround

But they have been around for a long time now, they appear once, and that's it and everything works.

Hopefully this is it for now.

I thank you very much for your help.
This time and for the several times in the past!
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  more debug messages kolive 7 2,787 04-30-2015, 05:03 PM
Last Post: kolive
  debug from 5401_b21 coconope 0 1,320 10-16-2014, 08:11 AM
Last Post: coconope



Users browsing this thread: 1 Guest(s)