Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connection error - (re: enable Public network)
#1
I have a question regarding the recent connection error issues users, including myself, are reporting.  I read the solutions, to enable the public network, to resume torrents. However, I neither want nor ever had that option active when Vuze used to work properly. It is clear by user reports that something has changed.

My question is:
1) Has the recent Vuze update fixed an bug that previously utilized public networks even though the option were disabled or 2) is there a new code that requires enabling public networks in order to use all other options?  I think many of us are a little more courious, or skeptical, about what is happening since this issure came to light.

Thank you.
Reply
#2
First of all it might be worth some explanation about the networks in vuze (Public, Tor, I2P). You may well fully understand this and if so please ignore it, but I'll go over it anyway for other potential readers.

Normally bittorrent works over the Public internet - trackers have public IP addresses, as do peers (sure, they could be using a VPN, but they still have a public IP address)

To use either the Tor or I2P networks (well, you shouldn't use Tor for anything other than tracking) you would need to manually install and configure the Tor/I2P software and then go ahead and configure Vuze appropriately - http://wiki.vuze.com/w/Anonymous_file_sh...or_and_I2P

You would then need to find torrents that are hosted on trackers run over those networks. 

Trackers on the Public internet will only give you the public IP addresses of peers (well, in theory they could hand out Tor/I2P ones but I have yet to see such a tracker - you would need to trust it a lot not to hand out the public IP address it has for you...) So if you have a 'normal' torrent with trackers such as udp://tracker.publicbt.com:80/announce they will only ever deal with public IP addresses. They will never give you an I2P or Tor network address.

Putting it another way, if you had an I2P torrent that could be downloaded over the I2P network, it would have a tracker with a 'hostname' ending in .i2p - an example being 

http://crs2nugpvoqygnpabqbopwyjqettwszth...9/announce

Before 5400 Vuze effectively ignored the default networks configured under Tools->Options->Connection and analysed the tracker addresses in the torrent file to work out what the Networks of the tracker URLs was. So if you added a torrent with public trackers the default enabled networks would be set to the Public network.

In 5400 network selection was added to the 'open torrent options' dialog (and flow). The logic added here used the default values specified in the configuration as the starting point as opposed to deriving a set of networks from the tracker hosts in the torrent.

Therefore from 5400 if you had deselected the Public network in the Network defaults section this would also be deselected on torrents when added. If the added torrent had Public trackers these now report 'network disabled'.

So to answer your questions specifically

1) 5400 fixed a bug whereby previously torrents were not inheritting the default enabled networks when they were added, rather they were being assigned a set of enabled Networks based on the tracker host names (ones ending in .i2p being assumed to be the I2P network, those ending in .onions the Tor network)

2) You need to ensure that the Public network is enabled on those torrents that use public trackers and talk to peers over the 'normal' IP network using public peer IP addresses. If you want to run over the I2P network then you need to look into how to configure that correctly and ensure that your torrents use I2P network based trackers (unless you are doing something advanced such as trying to mix multiple networks on a torrent)

Hopefully this explains what you are seeing?
Reply
#3
Thank you Parg! 

That was a great explination and I appreciate the time you took to write it.

I will be making some changes for future torrents. :)
Reply
#4
No problem, keep em coming!
Reply
#5
(08-29-2014, 01:40 PM)'Ebby' Wrote: I have a question regarding the recent connection error issues users, including myself, are reporting.  I read the solutions, to enable the public network, to resume torrents. However, I neither want nor ever had that option active when Vuze used to work properly. It is clear by user reports that something has changed.

My question is:
1) Has the recent Vuze update fixed an bug that previously utilized public networks even though the option were disabled or 2) is there a new code that requires enabling public networks in order to use all other options?  I think many of us are a little more courious, or skeptical, about what is happening since this issure came to light.

Thank you.

 


I Had a similar problem. My Vuze stopped downloading recently all of a sudden. I went to the TOOLS menus and then to IP filer and checked my IP ports. Then the IP port was not working. neither for incoming singnals or outgoing one. I do not know how to fis the problem. My guess is that I have to use different IP port but I do not know what port number to choose there. anyone can help please? I will need to download some films for my lessons I planned in my work, and I am desparate.

Thanks 
 


Attached Files
.docx   screen-print.docx (Size: 263.39 KB / Downloads: 3)
Reply
#6
Without looking it up I can only give you a rough port range.  Use a port in the range of 50,000 to 60,000.

The actual recomended port range is a little larger than that . . . but that is a good range.
Reply
#7
(09-02-2014, 11:25 AM)'GaryE' Wrote: Without looking it up I can only give you a rough port range.  Use a port in the range of 50,000 to 60,000.

The actual recomended port range is a little larger than that . . . but that is a good range.

 


Thank you very much. I will try this. Sam
 
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  VPN Connection issue/question QDog 3 1,426 01-08-2017, 03:07 PM
Last Post: trgarner
  Do you want the application “Vuze.app” to accept incoming network connections? daskarzine 6 6,336 11-25-2016, 04:05 PM
Last Post: parg



Users browsing this thread: 1 Guest(s)