Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bind To Local IP Address or Interface Weird Issue
I am using PIA for my VPN and have been for several years flawlessly with the bind function. When PIA would disconnect the routing would turn red and all the torrents would stop.

Recently I got a new modem from my ISP and ever since the bind function does not work correctly. If my PIA goes down or I disconnect it, Vuze switches the bind interface to my local connection. I am wondering if it is because they both start with 10. I ran the VPN helper for PIA and it lists both PIA and my local connection as bindable. When I disconnect frm PIA the dialog in the helper says that the binding was changed from eth4 to eth3.

I have never had this issue before. Any help would be greatly appreciated.
Please uninstall the vpnpia plugin (Tools->Plugins->Uninstall Plugins), and install the VPN Helper plugin

You will need to set the VPN Helper to "Private Internet Access" in the config.  A restart of Vuze is probably wise too.  

The VPN Helper plugin has more logic around 10.* addresses, which appears to be the problem you are running into.  Worse case, there's an additional config option inside the plugin to mark an interface or IP address as "not the VPN".

Hope that helps!
I ended up figuring this out yesterday. The only thing that worked is to uninstall both the vpnpia plugin and the VPNhelper plugin. After uninstalling both it is back to working how it should.

Not sure what that means but works for me now.

Possibly Related Threads...
Thread Author Replies Views Last Post
  New router - NAT/Port Forwarding issue SaxBlaCussionizer 2 12,004 07-09-2018, 04:44 PM
Last Post: SaxBlaCussionizer
  Java 9 issue, failing to load, +Firefox magnet link setup failing Melchior 3 11,624 03-13-2018, 06:50 AM
Last Post: Melchior

Users browsing this thread: 1 Guest(s)