Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Avoiding adaptive traffic shaping
I have 3 internet connections (3 WAN).
WAN #1 and WAN #2 have a high download speed, but a slow upload speed (5 mbps upload), so I don't like using them for uploading as it bothers other people using these WANs.
WAN #3 is the one I use for download/seeding torrents, however it has an adaptive hardware traffic shapening (Level 5+). 200mbps down / 100mbps up.
I have a firewall which manages this 3 wans.
My torrent box has several IPs. Let's call them,,, for simplicity.
My rules are the following the main IP uses the primary uplink interface (one of the 3 WANs that I set as default or one the is online). uses WAN #1 uses WAN #2 uses WAN #3
I bind Azureus/Vuze only to my IP.
I have almost all recommended setting for level 5.The only one I didn't modified is the "adjust DHT settings".
I also have the lazy bit field. IP address was assigned to it 
Level 5 is only intended for people who have problems with a specific traffic shaping method employed by sandvine traffic shaping hardware, see Bad ISPs to discover if this applies to you. The premise of this method is to minimize the amount of unencrypted information leaked. To enable it select following settings:
    Tools -> Options -> Connection -> Transport Encryption (See here)
        Enable require encryption
        Select RC4
        Disable both fallback checkboxes
    Tools -> Options -> Tracker -> Client
        Enable Do not announce the listening port to the tracker
        Set the peer limit to a low figure, start with 1 or 2
        set the Minimum time between tracker announces to 900 for example
Adjust DHT settings (2 mutually exclusive alternatives):
        Disable the DHT:
            Go to Tools -> Options -> Plugins -> Distributed DB and uncheck Enable the distributed database
        Try to get more peers via DHT:
            Go to Tools -> Options -> Plugins -> Distributed Tracker and uncheck Only track normal torrents[...]
    Try to seed a torrent you haven't seeded within the last few hours or so before applying these settings

The first few hours everything is working wonders, almost full upload speeds (60mbps-70mbps) (I limit to 80% of the maximum upload speed).
However after 5-6 hours, the adaptive traffic shapening starts to throttle my connection (only P2P such as bittorrent, IRC-XDCC, etc.), reducing both my download and my upload speed to no more than 1mbps.
The only solution I found was to reset the modem and wait for it to assing a new IP address.
If I don't close Vuze before doing it, it takes around 15 min-30 min for it to start shapening again. (I don't change the TCP/UDP port)
I also noticed that my Sophos UTM detects almost instantly the Bittorrent traffic, right after I open my azureus/vuze. Some of them it mistakens for Freenet protocol (some of the torrent udp connections).
Is there a way to circumvent this?
I thought of doing something like this: Using WAN #1 or WAN #2 for tracker, distributed DB, DHT management, etc... (as they don't throttle my traffic), and only using WAN #3 for direct P2P downloading (but preventing WAN #1 or WAN #2, as I don't want to use their connection for downloading/seeding). However, I not sure if it’s supported by Vuze.


Users browsing this thread: 1 Guest(s)