Community Forums

Home » Vuze Forums » Community Open Support


Thread: vuze not working on openSUSE 11.4


Thread Locked This thread is locked - replies are not allowed.


This question is answered. Helpful answers available: 2. Correct answers available: 1.

Search Forum Search Forum Back to Thread List Back to Thread List

Permlink Replies: 9 - Pages: 1 - Last Post: Jun 15, 2011 8:37 AM Last Post By: sleducator
tosiara


Posts: 8
Registered: 10/21/08
vuze not working on openSUSE 11.4
Posted: Apr 4, 2011 3:42 AM
 
Click to report abuse...
Hello,

I have downloaded latest Vuze 4.6 for 32bit Linux today

When I run ./azureus I receive error:
user@tsg-test-3:~/Download/vuze2/vuze> ./azureus
Starting Azureus...
Suitable java version found http://java = 1.6.0_24
Configuring environment...
Java exec found in PATH. Verifying...
Browser check failed with: Cannot load 64-bit SWT libraries on 32-bit JVM
Auto-scanning for GRE/XULRunner. You can skip this by appending the GRE path to LD_LIBRARY_PATH and setting MOZILLA_FIVE_HOME.
checking /usr/lib/seamonkey for GRE
Can not use GRE from /usr/lib/seamonkey because it's missing libxpcom.so.
checking /usr/lib/xulrunner-2.0 for GRE
GRE found at /usr/lib/xulrunner-2.0.
Browser check failed with: Could not initialize class org.eclipse.swt.widgets.Display
Can't create browser. Will try to set LD_LIBRARY_PATH and hope Vuze has better luck.
setting LD_LIBRARY_PATH to: /usr/lib/xulrunner-2.0
setting MOZILLA_FIVE_HOME to: /usr/lib/xulrunner-2.0
Loading Azureus:
java -Xmx128m -cp "./Azureus2.jar:./swt.jar" -Djava.library.path="/home/user/Download/vuze2/vuze" -Dazureus.install.path="/home/user/Download/vuze2/vuze" -Dazureus.script="./azureus" -Dazureus.script.version=2 org.gudy.azureus2.ui.swt.Main
file:/home/user/Download/vuze2/vuze/Azureus2.jar ; file:/home/user/Download/vuze2/vuze/swt.jar ; file:/home/user/Download/vuze2/vuze/
changeLocale: Default Language != English (United States). Searching without country..
changeLocale: Searching for language English in any country..
changeLocale: no message properties for Locale 'English (United States)' (en_US), using 'English (default)'
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:114)
at org.gudy.azureus2.ui.swt.Main.main(Main.java:292)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.aelitis.azureus.launcher.MainExecutor$1.run(MainExecutor.java:37)
at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.UnsatisfiedLinkError: Cannot load 64-bit SWT libraries on 32-bit JVM
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:194)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:174)
at org.eclipse.swt.internal.C.<clinit>(C.java:21)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(SWTThread.java:84)
at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThread.java:63)
at com.aelitis.azureus.ui.swt.Initializer.<init>(Initializer.java:163)
... 12 more
Exit from Azureus complete
No shutdown tasks to do
Azureus TERMINATED.

So it seems like Vuze ships 64bit SWT library for 32 bit Linux.
Ok, no problem, I went to Eclipse and downloaded correct SWT and overwrote swt.jar
(http://forum.vuze.com/thread.jspa?threadID=96990&tstart=0)

Now Vuze starts and I can see the window for 1 sec. After that Vuze crashes:

user@tsg-test-3:~/Download/vuze2/vuze> ./azureus
Starting Azureus...
Suitable java version found http://java = 1.6.0_24
Configuring environment...
Java exec found in PATH. Verifying...
Browser check failed with: InvocationTargetException, No more handles Unknown Mozilla path (MOZILLA_FIVE_HOME not set)
Auto-scanning for GRE/XULRunner. You can skip this by appending the GRE path to LD_LIBRARY_PATH and setting MOZILLA_FIVE_HOME.
checking /usr/lib/seamonkey for GRE
Can not use GRE from /usr/lib/seamonkey because it's missing libxpcom.so.
checking /usr/lib/xulrunner-2.0 for GRE
GRE found at /usr/lib/xulrunner-2.0.
Browser check failed with: InvocationTargetException, XPCOM error -2147467261
Can't create browser. Will try to set LD_LIBRARY_PATH and hope Vuze has better luck.
setting LD_LIBRARY_PATH to: /usr/lib/xulrunner-2.0
setting MOZILLA_FIVE_HOME to: /usr/lib/xulrunner-2.0
Loading Azureus:
java -Xmx128m -cp "./Azureus2.jar:./swt.jar" -Djava.library.path="/home/user/Download/vuze2/vuze" -Dazureus.install.path="/home/user/Download/vuze2/vuze" -Dazureus.script="./azureus" -Dazureus.script.version=2 org.gudy.azureus2.ui.swt.Main
file:/home/user/Download/vuze2/vuze/Azureus2.jar ; file:/home/user/Download/vuze2/vuze/swt.jar ; file:/home/user/Download/vuze2/vuze/
changeLocale: Default Language != English (United States). Searching without country..
changeLocale: Searching for language English in any country..
changeLocale: no message properties for Locale 'English (United States)' (en_US), using 'English (default)'
UIFunctions/ImageLoad took 26ms
new shell took 76ms
new shell setup took 27ms
skin init took 102ms
MainMenu init took 54ms
pre skin widgets init took 0ms
WARNING: already added UIUpdatable com.aelitis.azureus.ui.swt.mdi.TabbedMDI@908881
skin widgets (1/2) init took 51ms
skin widgets (2/2) init took 51ms
pre SWTInstance init took 0ms
Init Core Columns took 77ms
SWTInstance init took 0ms
shell.layout took 0ms
---------SHOWN AT 1301913257437;1179ms
---------DONE DISPATCH AT 1301913258277;2019ms
---------READY AT 1301913258727;2469ms
shell.open took 1290ms
processStartupDMS took 0ms
vuzeactivities init took 0ms
Locale Initializing took 0ms
44559: Core: 54ms for activity between 'Loading Plugin: hvi' and 'Loading Plugin: azupnpav'
44625: Core: 52ms for activity between 'Loading Plugin: aefeatman_v' and 'Loading Torrents'
44733: Core: 79ms for activity between 'Loading Plugin: azplugins' and 'Loading Plugin: azrating'
44980: Core: 26ms for activity between 'Loading Plugin: Buddy' and 'Loading Plugin: RSS'
45198: Core: 208ms for activity between 'Loading Plugin: RSS' and 'Initializing Plugin: HVI-DHT-Booster'
HVI-Plugin:hvi.HVI:200:initialize() first line
45250: Core: 42ms for activity between 'Initializing Plugin: Vuze Feature Manager' and 'Initializing Plugin: Tracker Static Pages'
HVI-Plugin:hvi.HVI:316:initialize() last line
45304: Core: 17ms for activity between 'Initializing Plugin: UPnP Media Server' and 'Initializing Plugin: Start/Stop Rules'
45313: Core: 17ms for activity between 'Initializing Plugin: Start/Stop Rules' and 'Initializing Plugin: Download Remove Rules'
45345: Core: 17ms for activity between 'Initializing Plugin: Universal Plug and Play (UPnP)' and 'Initializing Plugin: Distributed DB'
45386: Core: 17ms for activity between 'Initializing Plugin: Platform-Specific Support' and 'Initializing Plugin: LAN Peer Finder'
Core Initializing took 964ms
plug NetStatus
DEBUG::Mon Apr 04 13:34:19 EEST 2011::com.aelitis.azureus.plugins.net.netstatus.NetStatusPlugin::log::252:
org.gudy.azureus2.plugins.ddb.DistributedDatabaseException: DHT not available
at org.gudy.azureus2.pluginsimpl.local.ddb.DDBaseImpl.throwIfNotAvailable(DDBaseImpl.java:213)
at org.gudy.azureus2.pluginsimpl.local.ddb.DDBaseImpl.addTransferHandler(DDBaseImpl.java:552)
at com.aelitis.azureus.plugins.net.netstatus.NetStatusProtocolTester.<init>(NetStatusProtocolTester.java:120)
at com.aelitis.azureus.plugins.net.netstatus.NetStatusPlugin$3$1.run(NetStatusPlugin.java:183)
at org.gudy.azureus2.core3.util.AEThread2$threadWrapper.run(AEThread2.java:299)
psDMS 9ms
#
  1. A fatal error has been detected by the Java Runtime Environment:#
  2. SIGSEGV (0xb) at pc=0xa558276e, pid=5262, tid=2824661872#
  3. JRE version: 6.0_24-b07# Java VM: Java HotSpot(TM) Client VM (19.1-b02 mixed mode linux-x86 )# Problematic frame:# C http://libxul.so+0xd6876e#
  4. An error report file with more information is saved as:# /home/user/Download/vuze2/vuze/hs_err_pid5262.log#
  5. If you would like to submit a bug report, please visit:# http://java.sun.com/webapps/bugreport/crash.jsp#
    ./azureus: line 188: 5262 Aborted ${JAVA_PROGRAM_DIR}java "${JAVA_ARGS}" -cp "${CLASSPATH}" -Djava.library.path="${PROGRAM_DIR}" -Dazureus.install.path="${PROGRAM_DIR}" -Dazureus.script="$0" $JAVA_PROPS $START_CLASS "$@"
    Exit from Azureus complete
    No shutdown tasks to do
    Azureus TERMINATED.

I tried this on two separate 32bit Linux machines - it always crashes.

My system:

openSUSE 11.4 32bit

mmore1q3


Posts: 6,194
Registered: 12/02/07
Re: vuze not working on openSUSE 11.4
Posted: Apr 4, 2011 4:03 AM   in response to: tosiara in response to: tosiara
 
Click to report abuse...
Browser check failed with: Cannot load 64-bit SWT libraries on 32-bit JVM

Any chance that you could reach the discussion about the identical problem with OpenSUSE from yesterday in this same board???

http://forum.vuze.com/thread.jspa?threadID=96990
tosiara


Posts: 8
Registered: 10/21/08
Re: vuze not working on openSUSE 11.4
Posted: Apr 4, 2011 4:22 AM   in response to: mmore1q3 in response to: mmore1q3
 
Click to report abuse...
Hi, yes I have found, I have read and included the link to that thread in my post
In that thread the issue has been resolved, but in my case I still have vuze crash. The issue is related to 11.4 version of openSUSE and Firefox 4
mmore1q3


Posts: 6,194
Registered: 12/02/07
Re: vuze not working on openSUSE 11.4
Posted: Apr 4, 2011 5:37 AM   in response to: tosiara in response to: tosiara
Helpful
Click to report abuse...
Oh, you have added the note to your original message.

Edited by: mmore1q3 on 04-Apr-2011 15:39
Is there anything else in the error logs?
JRE version: 6.0_24-b07# Java VM: Java HotSpot(TM) Client VM (19.1-b02 mixed mode linux-x86 )
  1. Problematic frame:
  2. C http://libxul.so+0xd6876e#
An error report file with more information is saved as:# /home/user/Download/vuze2/vuze/hs_err_pid5262.log#

That error is coming from inside Mozilla XUL modules (libxul.so), so it might be something not easily fixed by anybody in Vuze or Eclipse (for SWT).
tosiara


Posts: 8
Registered: 10/21/08
Re: vuze not working on openSUSE 11.4
Posted: Apr 4, 2011 6:15 AM   in response to: tosiara in response to: tosiara
 
Click to report abuse...
Hello,

Seems like I have found a solution.
The crash occurs because openSUSE ships FIREFOX 4 and mozilla-xulrunner20

You need to install additional package: mozilla-xulrunner192

Now vuze starts fine

I think it's worth to add this info into troubleshouting wiki section or even make a fix to vuze so it loads or requires correct modules

Thanks!

Edited by: tosiara on Apr 4, 2011 6:24 AM
Matias Blana

Posts: 1
Registered: 04/09/11
Re: vuze not working on openSUSE 11.4
Posted: Apr 9, 2011 8:07 AM   in response to: tosiara in response to: tosiara
 
Click to report abuse...
Thank you very much! I had the same problem and your solution worked just fine!
ukstar

Posts: 2
Registered: 05/04/11
Problem with Fedora 14
Posted: May 4, 2011 11:24 AM   in response to: tosiara in response to: tosiara
 
Click to report abuse...
Trying to get away from Windows so installed Vuze on Fedora 14 32bit. Installed OK and can downlkoad videos etc., but the links to Vuze+ activation key or any links to more info don't work. Any ideas?
Thanks
WLS

Posts: 131
Registered: 02/09/11
Re: Problem with Fedora 14
Posted: May 4, 2011 1:32 PM   in response to: ukstar in response to: ukstar
 
Click to report abuse...
Don't hijack somone elses thread with a different problem. Start your own.

http://forum-services-review.toptenreviews.com/25-forum-posting-etiquette-tips.html

Edited by: WLS on May 4, 2011 4:37 PM
ukstar

Posts: 2
Registered: 05/04/11
Re: Problem with Fedora 14
Posted: May 4, 2011 5:55 PM   in response to: WLS in response to: WLS
 
Click to report abuse...
Just joined, finding my way around. Thanks for your help.
sleducator

Posts: 1
Registered: 06/15/11
Re: vuze not working on openSUSE 11.4
Posted: Jun 15, 2011 8:37 AM   in response to: tosiara in response to: tosiara
 
Click to report abuse...
http://eclipse.ialto.org/eclipse/downloads/drops/R-3.6.2-201102101200/swt-3.6.2-gtk-linux-x86_64.zip

download the above file and copy included swt.jar to /vuze and to /vuze/vuze

Legend
Master: 800 - 9999 pts
Expert: 400 - 799 pts
Advanced: 200 - 399 pts
Intermediate: 100 - 199 pts
Beginner: 50 - 99 pts
Newbie: 0 - 49 pts
Vuze Staff Member
Vuze Community Moderator
Helpful Answer (3 pts)
Correct Answer (5 pts)

Point your RSS reader here for a feed of the latest messages in all forums