Community Forums

Home » Vuze Forums » Community Open Support


Thread: Segmentation fault in libxul on Vuze startup, several Vuze versions


Thread Locked This thread is locked - replies are not allowed.


Search Forum Search Forum Back to Thread List Back to Thread List

Permlink Replies: 1 - Pages: 1 - Last Post: Dec 16, 2010 4:26 AM Last Post By: catkin
catkin


Posts: 9
Registered: 02/08/10
Segmentation fault in libxul on Vuze startup, several Vuze versions
Posted: Feb 26, 2010 9:22 PM
Click to report abuse...
On starting Vuze from the command line (with no ~/.azureus directory and no Vuze files in /tmp) a segmentation fault occurs in libxul. This has been seen with Vuze 4.2.0.8, 4.3.1.0 and 4.3.1.4. It does not happen with Vuze 4.1.0.4.

The OS is Slackware 13.0 32-bit, Firefox is 3.5.3.

The fault happened with both jre-6u16 and jre-6u18.

swt.jar in Vuze 4.3.1.4 is version 3.550. It was experimentally replaced with 3.631 but the fault remained (with less error reporting).

The attached error log was generated by running Vuze 4.3.1.4 with its standard swt.jar (version 3.550) and jre-6u18.

Versions in more detail:
catkin


Posts: 9
Registered: 02/08/10
Problem "gone away" on versions upgrade
Posted: Dec 16, 2010 4:26 AM   in response to: catkin in response to: catkin
Click to report abuse...
This problem "went away" running Vuze 4.5.1.0 on a fresh installation of Slackware64 13.1 including jre 6u20 (no jdk) and Firefox 3.6.12 (presumably including its own xulrunner).
Legend
Master: 800 - 9999 pts
Expert: 400 - 799 pts
Advanced: 200 - 399 pts
Intermediate: 100 - 199 pts
Beginner: 50 - 99 pts
Newbie: 0 - 49 pts
Vuze Staff Member
Vuze Community Moderator
Helpful Answer (3 pts)
Correct Answer (5 pts)

Point your RSS reader here for a feed of the latest messages in all forums