Community Forums

Home » Vuze Forums » Community Open Support


Thread: Azureus 100% CPU utilization 10.5 bug?


Thread Locked This thread is locked - replies are not allowed.


This question is not answered. Helpful answers available: 3. Correct answers available: 1.

Search Forum Search Forum Back to Thread List Back to Thread List

Permlink Replies: 4 - Pages: 1 - Last Post: Apr 1, 2012 11:57 PM Last Post By: roymarhall
dimpossibility

Posts: 1
Registered: 11/18/07
Azureus 100% CPU utilization 10.5 bug?
Posted: Nov 18, 2007 8:54 AM
 
Click to report abuse...
I am using Mac OS X.5.1 (latest Mac OS)
on an iMac G5 (1.8GHz with 2Gb RAM)
Azureus 3.0.3.4
Java J2SE 1.5

When I start Azureus, my CPU activity cranks to 100% within a few seconds. In Activity Monitor I see "mds" and "mdsworker" grabbing a lot of that activity (typically 60-80%). I checked online Mac forums and discovered (hopefully it's correct info) that "mds" is related to the Spotlight function. I opened the Spotlight System Preference panel and excluded the System, Library, and Azureus Download folders hoping to stop Spotlight from ramping up CPU usage during Azureus use. It has been several days but I still get 100% CPU utilization when I use Azureus (no other application causes this "mds" grab of CPU).

I really like Azureus. I even donated to the project. But I am using Transmission until someone can address this issue.

Thanks

John William
The 8472

Posts: 2,169
Registered: 11/13/07
Re: Azureus 100% CPU utilization 10.5 bug?
Posted: Nov 18, 2007 9:16 AM   in response to: dimpossibility in response to: dimpossibility
 
Click to report abuse...
well, since this seems to be a problem external to azureus i suggest you try to find out which files spotlight is indexing, e.g. you could check the open file handles with the lsof command (assuming osx has that too). Azureus is obviously rather heavy when it comes to disk access with all the randomized downloading, log files etc... so it could be a misconfiguration in spotlight that is only exposed when Az is active.
Peter
Re: Azureus 100% CPU utilization 10.5 bug?
Posted: Dec 6, 2007 4:27 PM   in response to: dimpossibility in response to: dimpossibility
Click to report abuse...
It's all the UI stuff in azureus that hogs the CPU in MacOS X.

Try closing some tabs, or better yet close the Azureus window entirely and watch you CPU usage drop.

Mine went from 106% to 12% on my Dual G5.
Fishbowler


Posts: 2,223
Registered: 11/29/07
Re: Azureus 100% CPU utilization 10.5 bug?
Posted: Dec 7, 2007 3:50 AM   in response to: dimpossibility in response to: dimpossibility
 
Click to report abuse...
I found this thread over at Apple's forums (running the same forum software, incidentally).

There are mentions of high CPU usage throughout, some attributed to being only during Azureus running.

See the options mentioned there. Try a few. Except disabling syslogd - that doesn't seem sensible

My favourites were:
-"Go into /Applications/Utilities and open Console.app. This program lets you read all of the log files on your computer. Browse through the logs until you find one that seems to be massive and has thousands of repeated messages in it. Those messages, whatever they are, will lead you to the offending application."
-"turning off Firewall Logging in Security"
-"disabling Back to My Mac"

Worth a try?
roymarhall

Posts: 4
Registered: 04/01/12
Re: Azureus 100% CPU utilization 10.5 bug?
Posted: Apr 1, 2012 11:57 PM   in response to: Fishbowler in response to: Fishbowler
 
Click to report abuse...
I'm a first time forum user. Hope this gets out there.

I have been downloading music and movies now for some time from Vuze Plus. Foolishly, I deleted nothing and now have over 50 downloads seeding. I feel that's the reason for 100% CPU Usage in Azereous which has my computer so blocked up I can't even delete anything. I tried deleting one at a time as well as deleting my whole library at one time. Nothing happens. I tried removing the program at "add/remove programs" on the control panel, and then reinstalled using my activation code. Same library and same problem came back. Once Azereous comes up, the computer is entirely frozen. Only way out is to hit "end process" in Task Manager.

Is there a simple way to clear my library for a beginner like me??

Thanks,

Roy
Legend
Master: 800 - 9999 pts
Expert: 400 - 799 pts
Advanced: 200 - 399 pts
Intermediate: 100 - 199 pts
Beginner: 50 - 99 pts
Newbie: 0 - 49 pts
Vuze Staff Member
Vuze Community Moderator
Helpful Answer (3 pts)
Correct Answer (5 pts)

Point your RSS reader here for a feed of the latest messages in all forums