Community Forums

Home » Vuze Forums » Community Open Support


Thread: Error On Vuze! (uses wrong Java JRE)


Thread Locked This thread is locked - replies are not allowed.


This question is not answered. Helpful answers available: 3. Correct answers available: 1.

Search Forum Search Forum Back to Thread List Back to Thread List

Permlink Replies: 3 - Pages: 1 - Last Post: Nov 25, 2010 10:04 AM Last Post By: mmore1q3
fleetheseen

Posts: 1
Registered: 10/08/08
Error On Vuze! (uses wrong Java JRE)
Posted: Oct 8, 2008 4:30 AM
 
Click to report abuse...
Hello people , I've been using Vuze for like a month , and everything goes well till recently ..

I can't open it or even uninstall it.

When i tried to open Vuze i got this Error :

"1st prompt:The JVM found at C:\Program files..etcetc\vuze\jre is damaged. Please reinstall or define EXE4J_JAVA_HOME to point to an installed JDK or JRE.

2nd prompt: The JVM Could not be started. The Main method may have thrown an exception.


When i tried to UINSTALL i got this Error :

1st prompt: The JVM found at {0} is damaged.
please reinstall or define EXE4J_JAVA_HOME to point to an installed 32-bit JDK or JRE.

2nd prompt is the same as the top.

Im using a Vista 64bit Home Prem.

I hope you guys can help me , thanks alot.

Edited by: mmore1q3 on 25-Nov-2010 19:59
clarified subject by adding Java reference
Washii

Posts: 5,261
Registered: 11/14/07
Re: Error On Vuze!
Posted: Oct 8, 2008 9:06 AM   in response to: fleetheseen in response to: fleetheseen
 
Click to report abuse...
Did you try reinstalling a 32-bit Java system, as the errors keep asking you to do?
xjonx1

Posts: 1
Registered: 02/10/09
Re: Error On Vuze!
Posted: Nov 25, 2010 9:47 AM   in response to: Washii in response to: Washii
 
Click to report abuse...
I am having the same problem and I have gone to Java and their website says I have the recommend version. I never had problems until the last update. How is this to be fixed?
mmore1q3


Posts: 6,194
Registered: 12/02/07
Re: Error On Vuze! (uses wrong Java JRE)
Posted: Nov 25, 2010 9:59 AM   in response to: xjonx1 in response to: xjonx1
 
Click to report abuse...
I guess that the original topic opener (and possibly also you, if you have the same error) has run into an related to Vuze installing an own version of Java, if there is no existing Java in your system at that point. And that Java is then got somehow corrupted.

I have reported that preference to self-installed Java JRE as an error: https://jira.vuze.com/browse/SUP-66

  • You should go to C:\Program Files\Common Files\i4j_jres\jre6 and delete that jre6 directory with all the subdirectories. (or whatever is the exact place in that error message. It points to a java JRE installed by the I4J installer system that Vuze uses.)

After that Vuze should use your normal Java installation.
(normally at C:\Program Files\Java\jre6 or C:\Program Files (x86)\Java\jre6 )
Legend
Master: 800 - 9999 pts
Expert: 400 - 799 pts
Advanced: 200 - 399 pts
Intermediate: 100 - 199 pts
Beginner: 50 - 99 pts
Newbie: 0 - 49 pts
Vuze Staff Member
Vuze Community Moderator
Helpful Answer (3 pts)
Correct Answer (5 pts)

Point your RSS reader here for a feed of the latest messages in all forums