Community Forums

Home » Vuze Forums » Community Open Support


Thread: Magnetic links from TPB will not work...


Thread Locked This thread is locked - replies are not allowed.


This question is answered.

Search Forum Search Forum Back to Thread List Back to Thread List

Permlink Replies: 17 - Pages: 1 - Last Post: Nov 25, 2009 10:26 AM Last Post By: boki
Shimrra

Posts: 2
Registered: 11/19/09
Magnetic links from TPB will not work...
Posted: Nov 19, 2009 11:01 AM
 
Click to report abuse...
So i am trying to download one of Top Gears specials, and I want to use TPB's new DHT links so I don't need a tracker, but when I try the link, the "operation in progress" window comes up and says 0% and then Failed
under details it lists:

Downloading From :magnet:?xt=urn:btih:3e7ecffa39a46269c6d519e49f09beb3249f7224&&&&...
Searching...
Error : no sources found for torrent

The full magnetic link is this:
magnet:?xt=urn:btih:3e7ecffa39a46269c6d519e49f09beb3249f7224&dn=Top+Gear+The+Challenges+Vol+2+KLAXXON&tr=http%3A%2F%2Fdenis.stalker.h3q.com%3A6969%2Fannounce

My setup from Help > About Vuze:
Java 1.6.0_17
Sun Microsystems Inc.
SWT v3550, win32
Windows XP v5.1, x86
V4.3.0.0/4 az3

Can anyone help me get this working?

nolar

Posts: 1,500
Registered: 11/13/07
Re: Magnetic links from TPB will not work...
Posted: Nov 19, 2009 12:09 PM   in response to: Shimrra in response to: Shimrra
Correct
Click to report abuse...
This will be fixed in the 4302 release we're starting to roll out now.
Shimrra

Posts: 2
Registered: 11/19/09
Re: Magnetic links from TPB will not work...
Posted: Nov 19, 2009 1:02 PM   in response to: nolar in response to: nolar
 
Click to report abuse...
Thank you!
nolar

Posts: 1,500
Registered: 11/13/07
Re: Magnetic links from TPB will not work...
Posted: Nov 19, 2009 1:15 PM   in response to: Shimrra in response to: Shimrra
 
Click to report abuse...
You can thank TPB for deciding not to be compatible with the magnet spec that's been used for 3 years now....

Anyway, 4302 is out and you can grab the installer from vuze.com or azureus.sf.net.
stephentan

Posts: 3
Registered: 11/20/09
Re: Magnetic links from TPB will not work...
Posted: Nov 20, 2009 12:37 AM   in response to: nolar in response to: nolar
 
Click to report abuse...
I'm a Mac user and I'm running Vuze 4.3.0.2.

  • Tried downloading the magnet link from TPB and nothing happened.

  • I copied the magnet link and manually added it under "add URL" - and I get a "failed" message.

Please advice.

Thanks.
cyb2063


Posts: 1,219
Registered: 11/13/07
Re: Magnetic links from TPB will not work...
Posted: Nov 20, 2009 1:00 AM   in response to: stephentan in response to: stephentan
 
Click to report abuse...
Make sure to have forwarded the needed ports properly. DHT and with it magnet links rely on an open UDP port.
http://azureuswiki.com/index.php/NAT_problem
nolar

Posts: 1,500
Registered: 11/13/07
Re: Magnetic links from TPB will not work...
Posted: Nov 20, 2009 11:35 AM   in response to: Shimrra in response to: Shimrra
 
Click to report abuse...
We're testing a patch for some OSX folks where the client gets activated, but doesn't load the passed magnet details.

However, I can open a TPB magnet link manually via File - Open - Torrent File: Add URL just fine under 4302. Keep in mind it may fail to download the behind-the-scenes torrent if you can't properly communicate with the DHT.
genemaster

Posts: 2
Registered: 11/20/09
Re: Magnetic links from TPB will not work...
Posted: Nov 20, 2009 2:36 PM   in response to: stephentan in response to: stephentan
 
Click to report abuse...
Same problem here on Mac (10.5) and Vuze 4.3.0.2

Depending on which link I try from TPB, I get the "no source" or "failed" error when I use the link with "open URL"
If I click the link in the browser (Safari), I get the "no source" or worse Vuze simply crashes....

Help (or update) needed....
Washii

Posts: 5,261
Registered: 11/14/07
Re: Magnetic links from TPB will not work...
Posted: Nov 20, 2009 2:41 PM   in response to: genemaster in response to: genemaster
 
Click to report abuse...
I get the "no source" or "failed" error when I use the link with "open URL"
Then they may not be publishing to the Vuze DHT stream, or DHT isn't starting on your client.
nolar

Posts: 1,500
Registered: 11/13/07
Re: Magnetic links from TPB will not work...
Posted: Nov 20, 2009 2:43 PM   in response to: genemaster in response to: genemaster
 
Click to report abuse...
For the no-source errors, that's likely due to the torrent not being particularly popular, so it can't find any peers for it in the dht. The good news is we should have a fallback service ready (today?) that will also look for peers on the utorrent dht.
nolar

Posts: 1,500
Registered: 11/13/07
Re: Magnetic links from TPB will not work...
Posted: Nov 20, 2009 7:17 PM   in response to: Shimrra in response to: Shimrra
 
Click to report abuse...
We decided to push a full 4304 release instead, which should be live now.
stephentan

Posts: 3
Registered: 11/20/09
Re: Magnetic links from TPB will not work...
Posted: Nov 20, 2009 11:14 PM   in response to: nolar in response to: nolar
 
Click to report abuse...
Hello Nolar

Cut and paste on 4304 does work with magnet links but not when you click on the link itself. Hopefully the next upgrade will sort that out.

Once again, thanks very much. At least that saved a lot of grief.
genemaster

Posts: 2
Registered: 11/20/09
Re: Magnetic links from TPB will not work...
Posted: Nov 21, 2009 11:10 AM   in response to: nolar in response to: nolar
 
Click to report abuse...
Thanks!!!!! The update fixed the problem for me. TBP magnet links now working.
nolar

Posts: 1,500
Registered: 11/13/07
Re: Magnetic links from TPB will not work...
Posted: Nov 21, 2009 1:23 PM   in response to: stephentan in response to: stephentan
 
Click to report abuse...
Restart your client and try again. Apparently one of the updates didnt get fully pushed last night, which hopefully explains why it didnt work when you tried before.
stephentan

Posts: 3
Registered: 11/20/09
Re: Magnetic links from TPB will not work...
Posted: Nov 22, 2009 3:41 PM   in response to: nolar in response to: nolar
 
Click to report abuse...
Hello Nolar
Thanks for your note. The magnet links are working fine now.
Cheers
boki

Posts: 2
Registered: 11/24/09
Re: Magnetic links from TPB will not work...
Posted: Nov 24, 2009 3:09 PM   in response to: Shimrra in response to: Shimrra
 
Click to report abuse...
it does not work fore me anyway. when I click the magnet link in TPB it just flashes and nothing happens. I have installed ver.4.3.0.4. Have tried uTorrent, works great but I have always use Vuze and want to continue with it, if possible
mmore1q3


Posts: 6,194
Registered: 12/02/07
Re: Magnetic links from TPB will not work...
Posted: Nov 24, 2009 11:04 PM   in response to: boki in response to: boki
 
Click to report abuse...
I noticed in my recently installed Win7 sandbox that magnet links worked well from IE, but as I had not teached Firefox that Vuze handles magnet, the links didn't work from Firefox.

Perhaps you should check your browser settings and make sure that there is the correct application assigned for magnet.
boki

Posts: 2
Registered: 11/24/09
Re: Magnetic links from TPB will not work...
Posted: Nov 25, 2009 10:22 AM   in response to: mmore1q3 in response to: mmore1q3
 
Click to report abuse...
I'm not so good at this. what should I do to make my settings to be correct application assigned for magnet links in TPB.
I'm using IE 8 and WIN-XP

Edited by: boki on 2009-nov-25 10:24
Legend
Master: 800 - 9999 pts
Expert: 400 - 799 pts
Advanced: 200 - 399 pts
Intermediate: 100 - 199 pts
Beginner: 50 - 99 pts
Newbie: 0 - 49 pts
Vuze Staff Member
Vuze Community Moderator
Helpful Answer (3 pts)
Correct Answer (5 pts)

Point your RSS reader here for a feed of the latest messages in all forums