Community Forums

Home » Vuze Forums » Open Development


Thread: Magnets trouble in RSSFeed Scanner


Thread Locked This thread is locked - replies are not allowed.


Search Forum Search Forum Back to Thread List Back to Thread List

Permlink Replies: 4 - Pages: 1 - Last Post: Mar 14, 2012 10:12 PM Last Post By: parg
dobri

Posts: 13
Registered: 11/30/09
Magnets trouble in RSSFeed Scanner
Posted: Mar 13, 2012 4:49 PM
Click to report abuse...
The current code of the RSSFeed Scanner is broken in regards to handling magnet URLs.
The issue is on line 319 of org.kmallan.azureus.rssfeed.Scheduler, which is supposed to differentiate between absolute and relative http URLs and converts the relative ones to absolute.
But it assumes that is cannot be anything else, and that may have been true in 2008 when this code was practically abandoned.

Replacing the original line

if(link.indexOf("://")) {

with

if(link.indexOf("://") < 0 && !link.startsWith("magnet")) {

solved the problem for me.
I tested it and it works both with filters and when clicking on a line in the Status view. It shows nicely in the history log too.
Sure it has certain delay before it starts the actual download, but this is how the magnet is designed to work. I did not see any issues with that, although spawning a separate thread to deal with it may be a nicer solution.

It can probably be improved further to deal with upper/lower case situations or other types of URLs, but this is the minimum required change.
parg

Posts: 2,698
Registered: 11/13/07
Re: Magnets trouble in RSSFeed Scanner
Posted: Mar 14, 2012 8:19 AM   in response to: dobri in response to: dobri
Click to report abuse...
thanks - I'll post an updated version with your fix
parg

Posts: 2,698
Registered: 11/13/07
Re: Magnets trouble in RSSFeed Scanner
Posted: Mar 14, 2012 8:58 AM   in response to: dobri in response to: dobri
Click to report abuse...
version 1.3.6 is live to beta/cvs users, perhaps you could check that it is working before I make it public?
dobri

Posts: 13
Registered: 11/30/09
Re: Magnets trouble in RSSFeed Scanner
Posted: Mar 14, 2012 8:10 PM   in response to: parg in response to: parg
Click to report abuse...
I tested the 1.3.6 beta and it is working.
parg

Posts: 2,698
Registered: 11/13/07
Re: Magnets trouble in RSSFeed Scanner
Posted: Mar 14, 2012 10:12 PM   in response to: dobri in response to: dobri
Click to report abuse...
thanks
Legend
Master: 800 - 9999 pts
Expert: 400 - 799 pts
Advanced: 200 - 399 pts
Intermediate: 100 - 199 pts
Beginner: 50 - 99 pts
Newbie: 0 - 49 pts
Vuze Staff Member
Vuze Community Moderator
Helpful Answer (3 pts)
Correct Answer (5 pts)

Point your RSS reader here for a feed of the latest messages in all forums