Community Forums

Home » Vuze Forums » Open Development


Thread: private torrents not seeding


Thread Locked This thread is locked - replies are not allowed.


This question is answered.

Search Forum Search Forum Back to Thread List Back to Thread List

Permlink Replies: 32 - Pages: 1 - Last Post: Sep 17, 2010 3:42 PM Last Post By: mongpa
mongpa

Posts: 37
Registered: 06/01/09
private torrents not seeding
Posted: Aug 31, 2010 12:37 AM
 
Click to report abuse...
I have a problem uploading private torrents. I use Vuze 4.5.0.2 and can't get seeding going. When I create a private torrent with Vuze and try to seed it, Vuze puts the torrent into my downloads pane and shows that it is incomplete. Vuze thinks the file I am trying to seed is only 99% complete each time. The force recheck command is dimmed for it so that I can't give that command. (It is also dimmed for each of my various downloads.) I am connected to 0 out of 0 seeds on each torrent that I am trying to seed and to 0 of 1 peers.

Materials used:
Mac PowerBook 1.25 GHz G4
2 GB DDR SDRAM
Mac OS X 10.4.11
Vuze 4.5.0.2

Edited by: mongpa on Aug 31, 2010 12:38 AM

Edited by: mongpa on Aug 31, 2010 12:40 AM
cyb2063


Posts: 1,219
Registered: 11/13/07
Re: private torrents not seeding
Posted: Aug 31, 2010 1:53 AM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
When I create a private torrent with Vuze and try to seed it, Vuze puts the torrent into my downloads pane and shows that it is incomplete. Vuze thinks the file I am trying to seed is only 99% complete each time.

Sounds like the torrent file and/or the data had been corrupted during/after torrent creation. Just delete the current torrent and try again. Also a faulty hard drive might be the problem.
mmore1q3


Posts: 6,194
Registered: 12/02/07
Re: private torrents not seeding
Posted: Aug 31, 2010 2:13 AM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
force recheck command is dimmed for it so that I can't give that command. (It is also dimmed for each of my various downloads.)
Force re-check is only active for "Stopped" torrents.
mongpa

Posts: 37
Registered: 06/01/09
Re: private torrents not seeding
Posted: Aug 31, 2010 2:58 AM   in response to: cyb2063 in response to: cyb2063
 
Click to report abuse...
I've deleted the torrent on my hard drive and on the tracker's web site and recreated the torrent multiple times without success. Also, I've run the most highly recommended diagnostic utility (DiskWarrior for Mac) on the hard drive and no errors were found.
mongpa

Posts: 37
Registered: 06/01/09
Re: private torrents not seeding
Posted: Aug 31, 2010 3:05 AM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
Also, the problem is only with private torrents I've created. There is no problem with seeding data I've downloaded and which has automatically gone from incomplete to complete.
mongpa

Posts: 37
Registered: 06/01/09
Re: private torrents not seeding
Posted: Aug 31, 2010 3:15 AM   in response to: mmore1q3 in response to: mmore1q3
 
Click to report abuse...
Re: "Force re-check is only active for "Stopped" torrents."

The "Stop" command has also ceased to function on each of my uploads and downloads. (Another strange behaviour is that to restart a torrent that was stopped some time ago, I now can't just give a "Queue" command. That does nothing. I have to choose "Force start" and then "Force start" a second time if I want to toggle it off.)
mmore1q3


Posts: 6,194
Registered: 12/02/07
Re: private torrents not seeding
Posted: Aug 31, 2010 3:39 AM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
The "Stop" command has also ceased to function on each of my uploads and downloads. (Another strange behaviour is that to restart a torrent that was stopped some time ago, I now can't just give a "Queue" command. That does nothing.
Update to beta 4503_B08. There was a problem regarding Queue and Stop, which has been corrected in Betas.
http://dev.vuze.com
mongpa

Posts: 37
Registered: 06/01/09
Re: private torrents not seeding
Posted: Aug 31, 2010 7:25 PM   in response to: mmore1q3 in response to: mmore1q3
 
Click to report abuse...
I've downloaded the latest beta, which is:
Azureus4503-B10.jar.

To install it on a mac, do I just open the Vuze package contents, locate the "Java" folder and in it replace the file, Azureus2.jar with the beta?
nolar

Posts: 1,500
Registered: 11/13/07
Re: private torrents not seeding
Posted: Aug 31, 2010 7:27 PM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
Yes, exactly.
nolar

Posts: 1,500
Registered: 11/13/07
Re: private torrents not seeding
Posted: Aug 31, 2010 7:28 PM   in response to: nolar in response to: nolar
 
Click to report abuse...
Or, if you're already on the 4.5 series, you can just use the Help --> Join Beta Programme... menu option in the client.
mongpa

Posts: 37
Registered: 06/01/09
Re: private torrents not seeding
Posted: Aug 31, 2010 8:22 PM   in response to: nolar in response to: nolar
 
Click to report abuse...
Vuze fails to launch when I install the beta that way. Also, I activated joining the beta program in the Help menu a day ago and have repeatedly given the Check for updates command but no updates have happened that way with my version of Vuze. Maybe that's another bug...
nolar

Posts: 1,500
Registered: 11/13/07
Re: private torrents not seeding
Posted: Aug 31, 2010 9:32 PM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
mongpa

Posts: 37
Registered: 06/01/09
Re: private torrents not seeding
Posted: Sep 1, 2010 1:19 AM   in response to: nolar in response to: nolar
 
Click to report abuse...
I've installed Vuze 4.5.0.4 for Mac OS X (the new version) and all is working well now except that the original problem, unable to seed a private torrent persists. I've created two new torrent files for two different data files using Vuze. I've uploaded the torrents to a private site, downloaded them from that site, double-clicked the downloads and chosen to open them for seeding. As before, the torrents appear in Vuze in the upper, incomplete pane as only 99% complete. The only difference from before is that the seeds and peers columns just each say 0.

With this Vuze upgrade, I can now stop each torrent and force a recheck. When I do that, the rechecking is almost instantaneous, then the reported % done drops from 99 to 0! I'm afraid I'm still not out of the woods here.
cyb2063


Posts: 1,219
Registered: 11/13/07
Re: private torrents not seeding
Posted: Sep 1, 2010 2:02 AM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
Sounds more and more like the site you upload to messes up the torrent. Maybe you could try another tracker.
AND4ever

Posts: 5
Registered: 09/01/10
Re: private torrents not seeding
Posted: Sep 1, 2010 1:28 PM   in response to: cyb2063 in response to: cyb2063
Correct
Click to report abuse...
I have the same problem with my own torrents, and I've tried two different private trackers with same negative result...
I then tried with a different client (Transmission) and everything hashed OK to 100% as it should do...
I then downgraded to Vuze 4.4.6.0 and everything is working again...
Something is screwed up in the later releases of Vuze at least on Mac OSX 10.4...
mongpa

Posts: 37
Registered: 06/01/09
Re: private torrents not seeding
Posted: Sep 1, 2010 4:32 PM   in response to: AND4ever in response to: AND4ever
 
Click to report abuse...
Where to get Vuze 4.4.6.0? I can't find the older versions on the web.
nolar

Posts: 1,500
Registered: 11/13/07
Re: private torrents not seeding
Posted: Sep 1, 2010 4:36 PM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
All old versions can be found in the archive: http://sourceforge.net/projects/azureus/files/vuze/
mongpa

Posts: 37
Registered: 06/01/09
Re: private torrents not seeding
Posted: Sep 1, 2010 8:07 PM   in response to: nolar in response to: nolar
 
Click to report abuse...
I've tried downgrading to Vuze 4.4.0.6 and encountered two problems:
a) "Error: Conversion from/to piece reorder not supported": Most my incomplete torrents and most of my completed ones have this error in the status column. The completed ones affected in this way move automatically to the incomplete pane and become 0% complete. (On upgrading to Vuze 4.5 again, all these torrents automatically go back to their previous state.)
b) plugins are not accessible, including Speed Scheduler. (On upgrading to Vuze 4.5 again, Speed Scheduler with all its settings automatically come back.)

I've tried having to Vuze 4.4.0.6 on a different startup disc and creating my torrents there, then switching to Vuze 4.5 for regular use, deleting the torrents there, uploading the torrents newly created with Vuze 4.4 to the tracker's site, downloading them again from there and using them to force a recheck. The original problem persists, unfortunately: only 99% complete and unable to seed.
mongpa

Posts: 37
Registered: 06/01/09
Re: private torrents not seeding
Posted: Sep 8, 2010 7:36 PM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
Now using Vuze 4.5.0.5_B05, I've tried creating the torrent with different piece sizes using all the possibilities available, without success in seeding.

Edited by: mongpa on Sep 8, 2010 7:37 PM
nolar

Posts: 1,500
Registered: 11/13/07
Re: private torrents not seeding
Posted: Sep 10, 2010 2:21 PM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
If I understand you correctly. You are creating a new torrent on your local machine, uploading that torrent to a tracker site, downloading and loading the new site torrent in the client, and Vuze is rechecking and then moves the torrent back to the downloading section at 99% ?

Sounds to me like your tracker site is modifying the torrent in some way.....like adding a readme.txt or something. If you upload a single-file torrent, do you get back an identical (set of) file from the tracker torrent?

It's kind of impossible to debug your problem without real torrents to test with, and exact step by steps of reproducing.
AND4ever

Posts: 5
Registered: 09/01/10
Re: private torrents not seeding
Posted: Sep 10, 2010 2:43 PM   in response to: nolar in response to: nolar
 
Click to report abuse...
It has something to do with "Switched to piece-reordering based file storage on OSX by default" which happened after 4.4.0.6
All versions works up 4.4.0.6 but not any later versions of Vuze...
And it could be that I'm using an old Mac OSX (10.4.11)
I tried several trackers and it just don't work...
And I can use the same torrent and get 100% if I use Transmission instead of Vuze so it's not a tracker or torrent problem...
It's caused by Vuze and as I already said my guess is the new piece-reordering bit that don't work...
nolar

Posts: 1,500
Registered: 11/13/07
Re: private torrents not seeding
Posted: Sep 10, 2010 3:07 PM   in response to: AND4ever in response to: AND4ever
 
Click to report abuse...
You can disable the piece reordering via Preferences -> Files: "Append data to files as downloaded and reorder pieces as the download progresses." option. (You may need to be in Mode: Advanced )
AND4ever

Posts: 5
Registered: 09/01/10
Re: private torrents not seeding
Posted: Sep 12, 2010 2:23 PM   in response to: nolar in response to: nolar
 
Click to report abuse...
YES! :D That did the trick... Now it's working again...
All I had to do was disable it...
Thanks for the advice, I don't know why I didn't see that earlier...
parg

Posts: 2,697
Registered: 11/13/07
Re: private torrents not seeding
Posted: Sep 14, 2010 10:01 AM   in response to: AND4ever in response to: AND4ever
 
Click to report abuse...
Try as I might I can't reproduce this :(

What kind of torrent are you creating? A single file one or one with multiple files?

Can you go through the exact steps to reproduce the problem?

What files are you torrenting up and what's their rough size?
Do you just create the torrent and upload it to the tracker, or do you initially add it to Vuze for seeding as well?
When you re-add the torrent, how do you do it? Add-for-seeding?

thanks

AND4ever

Posts: 5
Registered: 09/01/10
Re: private torrents not seeding
Posted: Sep 14, 2010 11:04 AM   in response to: parg in response to: parg
 
Click to report abuse...
I'm creating a torrent for a folder containing multiple files (mainly flac-files and some artwork) 300-500 MB
I let Vuze decide the piece size automatic and then I upload the torrent to the private tracker, then download it from the tracker with my passkey...
Then I add it to Vuze and point it to my folder containing the files for the torrent...
Wait for it to hash check and then I seed away... :D
I've tried three different trackers with the same result with the new "piece order" (or wahtever it's called) and it just don't hash 100%...
I've tried four different folders and all of them works fine with Vuze if I disable the "piece order" or if I use for example Transmission instead of Vuze...
But as soon as I don't disable it in Vuze it hashes maybe 98-99% and then try to download the rest????
I'm using Mac OSX 10.4.11 that may have something to do with the trouble, I don't have a clue...
But I've read about other users with the same problems on different tracker forums...
parg

Posts: 2,697
Registered: 11/13/07
Re: private torrents not seeding
Posted: Sep 14, 2010 2:53 PM   in response to: AND4ever in response to: AND4ever
 
Click to report abuse...
And the same error occurs if you don't go through the act of uploading the torrent and re-downloading it - that is, you simply add the torrent?
parg

Posts: 2,697
Registered: 11/13/07
Re: private torrents not seeding
Posted: Sep 14, 2010 3:01 PM   in response to: parg in response to: parg
 
Click to report abuse...
maybe you could send me over an example torrent that exhibits the problem? paul- at -vuze- dot -com please.

thanks!
AND4ever

Posts: 5
Registered: 09/01/10
Re: private torrents not seeding
Posted: Sep 15, 2010 11:10 AM   in response to: parg in response to: parg
 
Click to report abuse...
Of course I always have to upload my selfmade torrent file to the private tracker and then downlaod it from the tracker...
That how it works on all private trackers... So no I haven't tried anything else since I'm not interested if that might work...
And no forget it... I won't send a private torrent to anyone I don't know and I already told you there is nothing wrong with the torrent, I've already tried other clients/applications (transmisson & utorrent) it's just Vuze that don't hash OK if you don't disable the new piece reording bit...
nolar

Posts: 1,500
Registered: 11/13/07
Re: private torrents not seeding
Posted: Sep 15, 2010 11:17 AM   in response to: AND4ever in response to: AND4ever
 
Click to report abuse...
He needs the torrent to try and reproduce what you are/were seeing, as we cannot reproduce in-house so far. Without seeing the bug in action, we can't possibly fix it.
Quench

Posts: 1
Registered: 09/16/10
Re: private torrents not seeding
Posted: Sep 16, 2010 2:26 PM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
quote

a) "Error: Conversion from/to piece reorder not supported": Most my incomplete torrents and most of my completed ones have this error in the status column. The completed ones affected in this way move automatically to the incomplete pane and become 0% complete. (On upgrading to Vuze 4.5 again, all these torrents automatically go back to their previous state.)
b) plugins are not accessible, including Speed Scheduler. (On upgrading to Vuze 4.5 again, Speed Scheduler with all its settings automatically come back.)

[/quote]

I had this exact problem
I do not keep vuze in the Applications folder but the updater puts the new version in there and runs it.
Then when I run again I am running the old version.
mongpa

Posts: 37
Registered: 06/01/09
Re: private torrents not seeding
Posted: Sep 17, 2010 4:52 AM   in response to: nolar in response to: nolar
 
Click to report abuse...
Hi. I posted the original message about this issue. I'm emailing parg directly with an example of a torrent with this problem attached.

I'm using Mac OS 10.4.11 too, which is not the latest version. Don't know if that is a coincidence or not.

The files I have tried torrenting up (two of them) are AVI and WMV. The former is 82.2 MB and the latter is 204.6 MB. Neither has multiple files and I haven't tried that.

What I've been doing (to reproduce the problem) is either:
a) create a torrent with Vuze, upload it to the private torrent's web site, download it again, and open it to force a recheck for seeding. This is all as per the private site's guidelines. Otherwise I get the same problem if I just:
b) create the torrent with Vuze, specifying that I want to open it for seeding when I create it. These days I just do this, without uploading it to the torrent site, to observe the problem still occurring.

To repeat, the problem is that the torrent subsequently appears in the incomplete pane of Vuze. It is 99% complete. Inspection of the pieces in the torrent shows that Vuze thinks that 3 pieces are missing. This is true for each of the two torrents I have tried.
parg

Posts: 2,697
Registered: 11/13/07
Re: private torrents not seeding
Posted: Sep 17, 2010 10:02 AM   in response to: mongpa in response to: mongpa
 
Click to report abuse...
Thanks - I've finally managed to reproduce the bug - looking into the fix!
mongpa

Posts: 37
Registered: 06/01/09
Re: private torrents not seeding
Posted: Sep 17, 2010 3:42 PM   in response to: parg in response to: parg
 
Click to report abuse...
The problem has been fixed with Vuze 4.5.0.5_b12. I'm successfully seeding two torrents newly created. Thanks to all who have contributed to fixing this problem.
Legend
Master: 800 - 9999 pts
Expert: 400 - 799 pts
Advanced: 200 - 399 pts
Intermediate: 100 - 199 pts
Beginner: 50 - 99 pts
Newbie: 0 - 49 pts
Vuze Staff Member
Vuze Community Moderator
Helpful Answer (3 pts)
Correct Answer (5 pts)

Point your RSS reader here for a feed of the latest messages in all forums