Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Vuze 5.5.0.0 plugin I2P Helper 0.4.16 does not perform valid query to i2p trackers.
#1
Since at plugin webpage http://www.vuze.com/plugins/details/azneti2phelper does not provide contact information, i will post it here. Anyone who knows developer Parg, say him to read this thread.

I joined I2P network and started to test its internal bittorrent network. Vuze + I2P Helper seemed best software available that support I2P. Dowloaded first torrent from Postman's tracker. Saw that its tracker reports: Missing key: ip (GET variable ip in announce link is missing).
Contacted tracker owner and asked why announces to it's tracker fails. Respond was:
Quote:
there is no error on the tracker's side. The I2P Bittorrent specification
requires the B64 full destination in the ip field. Please forward your request
to the vuze plugin developers.
Started to check I2P Helper's settings page only provides .b32.i2p (60 symbols total) like adresses but not full destination (516 symbols + .i2p). After few days found working workaround:
Quote:
1. Find dest_key.dat or dest_key1.dat under application data folder for vuze (usually at %APPDATA\Azureus\plugins\azneti2phelper)
2. Choose one of them and copy first 384 bytes somewhere
3. Apply base64 encoding
4. Replace + to - and / to ~ or %7E and add AAAA.i2p
5. Add to http://tracker2.postman.i2p/announce.php?ip= previously made string and use it as tracker address.
I2P Helper developer should fix this bug to make Vuze more easy to use.
Reply
#2
I was under the  impression that the tracker had access to the destination implicitly (by the fact that it has a connection established). The ip= entry is usually used as an 'override' - that is to specify an address *other* than the implicit request originator. However, I can take a look 
Reply
#3
Actually it looks as if I already do it :(

sb.append( "&ip=" + getSocketManager( options ).getSession().getMyDestination().toBase64() + ".i2p" );

and I just tested and it seems to send that correctly...

Make sure you have a recent version of the plugin - join the beta program to get the latest as it might have been broken in a previous version, not sure
Reply
#4
Joined beta program. Reinstalled i2p helper plugin - no changes. Where i can find your lastest version? https://www.google.lv/search?q=i2phelper shows nothing new.

Edit:
Nothing in https://www.google.lv/search?q=site:dev.vuze.com+i2p
Edit 2;
Nothing new in http://plugins.vuze.com/plugin_details.p...os=Windows
Reply
#5
(11-27-2014, 06:41 PM)'parg' Wrote: Actually it looks as if I already do it :(

sb.append( "&ip=" + getSocketManager( options ).getSession().getMyDestination().toBase64() + ".i2p" );

and I just tested and it seems to send that correctly...

Make sure you have a recent version of the plugin - join the beta program to get the latest as it might have been broken in a previous version, not sure

 
Is your software open source?


 
Reply
#6
https://svn.vuze.com/public/plugins/netw...i2phelper/

The code that builds the announce request is here, line 979

https://svn.vuze.com/public/plugins/netw...Proxy.java

The socks code intercepts and modifies the tracker requests.
Reply
#7
(11-28-2014, 10:30 AM)'parg' Wrote: https://svn.vuze.com/public/plugins/netw...i2phelper/

The code that builds the announce request is here, line 979

https://svn.vuze.com/public/plugins/netw...Proxy.java

The socks code intercepts and modifies the tracker requests.

 


Where i can download plugin that does that? Plugin found http://plugins.vuze.com/plugin_details.p...os=Windows does not add ip variable.
 
Reply
#8
It does add an ip variable, at that line number - all the source for the plugin is there:

https://svn.vuze.com/public/plugins/netw...i2phelper/

that *is* the azneti2phelper plugin
Reply
#9
(11-28-2014, 11:35 AM)'parg' Wrote: It does add an ip variable, at that line number - all the source for the plugin is there:

https://svn.vuze.com/public/plugins/netw...i2phelper/

that *is* the azneti2phelper plugin

 

I want compiled plugin (*.jar) or better *.vuze plugin package not it's source. I don't want to install any compilers and my computer does not have space for it.

 
Reply
#10
do i need to send you network monitoring data to prove it is not working? You may add line that dumps requested url to debug log.
Reply
#11
So you have installed the azneti2pelper plugin (I2P Helper Plugin) , NOT the deprecated 'I2P Network Plugin', and you haven't manually configured any SOCKS servers within Vuze regarding I2P.

What version of the plugin do you have (go to Tools->Options and click on the Plugins entry to show version information on the right)?

You can see some activity in the log under Tools->Plugins->Log Views->I2P Helper although this is mainly router stats and DHT stuff

Feel free to send me the torrent causing problems (paul@vuze.com) - I can verify that it works for me.
Reply
#12
parg\ dateline='\'1417280909' Wrote: So you have installed the azneti2pelper plugin (I2P Helper Plugin) , NOT the deprecated 'I2P Network Plugin', and you haven't manually configured any SOCKS servers within Vuze regarding I2P.

What version of the plugin do you have (go to Tools->Options and click on the Plugins entry to show version information on the right)?

You can see some activity in the log under Tools->Plugins->Log Views->I2P Helper although this is mainly router stats and DHT stuff

Feel free to send me the torrent causing problems (paul@vuze.com) - I can verify that it works for me.

 

It shows I2P Helper version is 0.4.16 as i mentioned. Wait for an e-mail.

Edit:
Sent an email. Maybe line
Code:
sb.append( "&ip=" + getSocketManager( options ).getSession().getMyDestination().toBase64() + ".i2p" );
fails because there is two destinations?

 
Reply
#13
Verified plugin - it contains that line. Found line sb.append( "&port=6881" );

but my request contains different port.
Reply
#14
Why is it connecting to the http proxy on port 4444? With the "I2P Helper" plugin you do NOT need to configure any proxy options within Vuze, the plugin handles everything...
Reply
#15
parg\ dateline='\'1417309543' Wrote: Why is it connecting to the http proxy on port 4444? With the "I2P Helper" plugin you do NOT need to configure any proxy options within Vuze, the plugin handles everything...
 
I have stable external i2p setup from https://geti2p.net/en/ and its proxy port for http is 4444. I2P plugin can't be sure what i configured on other side. Looks like you assumed i am using default configuration where i2p helper is a router. I needed to set up that proxy because vuze tried to reach i2p trackers outside i2p network.

Edit:
My email title was
Quote:Simple I2P Helper plugin 0.4.16 communication with existing I2P installation to port 4444
, looks like you read only very last part of it :D
Reply
#16
The 'I2P Helper' plugin doesn't use I2P's HTTP proxy - it uses the external router's I2CP port only (default 7654)

Go to Tools->Options->Connection->Proxy and make sure you don't have ANY proxy specified there

Go to Tools->Options->Plugins->I2P Helper and make sure you have configured and enabled your external router's I2CP port towards the bottom.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Webtorrent wss trackers not working garycee 14 289 01-03-2017, 01:47 PM
Last Post: parg
  What does this mean Rob B 18 1,454 12-29-2016, 12:41 PM
Last Post: galleherjazz



Users browsing this thread: 2 Guest(s)