Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HELP: The application was unable to start correctly (0xc000007b).
#1
DESCRIPTION OF THE PROBLEM

The problem I am having is that Vuze will not start on my new Laptop (Gigabyte P35Xv4-BW3K2) after upgrading to Windows 10.
Whenever I start Vuze I get the following error message:
Azureus.exe - Application Error
The application was unable to start correctly (0xc000007b). Click OK to close the application.

This means that I cannot open Vuze at all. Sadly this is a huge issue for me as I believe my ISP is blocking Torrent traffic and so far Vuze was the only BitTorrent client I could setup in such a way that it would bypass this.
I would be extremely grateful for any information on how to fix this problem!

    NOTES    :    System restore is sadly not an option as I had not made one.
            Rerolling back to Windows 8.1 is also not an option as I deleted the Windows.old files since everything seemed to be working.
            Reinstalling is also not really an option since I have spent the last 4-5 days installing and getting everything setup with the multitude of applications I run and specific settings etc.


MY SPECIFICATIONS & INFORMATION

    1. Operating System and version
        Windows 10 (64-Bit) upgraded from Windows 8.1 (64-Bit) the standard edition not Win 8.1 Pro

    2. The text from the 'System' area on the 'About' page (Help -> About or Vuze -> About)
        Cannot boot the application so cannot say what it is on the device with the problems.
            On my previous Laptop running Windows 8.1 (64-Bit) Enterprise    :    Java 1.8.0_45 Oracle Corporation SWT v4508, win32 Windows 8.1 v6.3, amd64 V5.6.2.0/4 az3
        Both systems had their Java installed via Ninite and as a Windows 8.1 (64-Bit) system
        I also manually installed Java from the Java website after I had update to Windows 10 on the new Laptop and was experiencing these problems.

    3. Antivirus software + version
        Currently only using Windows Defender. Have also tried with Windows Defender in a turned off state.
        I used Windows Defender up until the posting of this thread and have just installed BitDefender.
            On my other laptop Vuze works with BitDefender.

    4. Firewall software + version
        No additional firewall software. Standard Windows firewall, cannot find an associated number.
            Works with my other laptop.

    5. Internet Service Provider and following information
        N/A problem is not related to connections.

    6. Using a Router and/or modem with Network Address Translation?
        XXXXXXXXXXXX

    7. If 'Yes' above, have you forwarded a port for Azureus?
        No specific forwarding rule.

    8. If 'Unknown' or 'Yes,' give us thd models for your router and/or modem
        Mikrotik RB450G Core Router with a Mikrotik RB750G router from the ISP
            - When connected via Ethernet the path is: Ethernet --> TP-Link TL-SG1008 --> Mikrotik RB450G --> Mikrotik RB750 --> Ethernet to Fibreoptic Converter
            - When connected via Wi-Fi the path is: : Wi-Fi --> Linksys WAG200G (Bridged) --> Mikrotik RB450G --> Mikrotik RB750 --> Ethernet to Fibreoptic Converter
            - Also tested with a different router: Wi-Fi --> TP-Link TL-WDR3600 (not bridged) --> Mikrotik RB450G --> Mikrotik RB750 --> Ethernet to Fibreoptic Converter
                All three work with my other laptop.

    9. Using a Wireless Connection?
        Yes.
            Works with my other laptop.

    10. If yes above, have you tried a wired connection instead?
         Yes.
             Works with my other laptop.

    11. Do the Health status on your torrents have Green smilies?
         Yellow. It said that this might have to do with NAT issues I am not sure on this.
         I strongly suspect the ISP is blocking torrent traffic as:
             - uTorrent torrents will not work on either machine (hover at 1.5-4.5KB/s)
             - Deluge torrents will not work on the current machine
        Therefore I am not sure if they are yellow because of NAT issues or because of my ISP.
        Nonetheless the issue remains that Vuze will not start on my new Laptop and is running just fine on the old one.


FIXES I HAVE TRIED

Versions tried:
    - Standard 5.6.2.0 Installer from the website
    - A 5.6.0.0 Installer specifically for x64

    1. Uninstall --> Reinstall
        a. With reboot
        b. Without reboot
        c. With setting clearing
        d. Without setting clearing
        e. Manually deleting:
            i.     Output folder i.e.: If I had set a specific folder for e.g.: automatic backups and torrents to be placed/moved in/to.
            ii.     AppData folder (C:\Users\<myusername>\AppData\Roaming\Vuze) including the folder Vuze not just its contents.
            iii.    C:\Program Files folder if left over (if I recall correctly it always deleted itself)
        f. Install without:
            i.      iTunes Integration
            ii.     Swarm Discoveries
            iii.    Message Sync
            iv.    Location Provider

    2. Uninstall --> Reinstall C++ Redistributable for Visual Studio (where possible)
        2010 x86                  :    A newer version of Microsoft Visual C++ 2010 Redistributable has been detected on the machine.
        2010 x64                  :    A newer version of Microsoft Visual C++ 2010 Redistributable has been detected on the machine.
        2012 Update 4 x86    :    Uninstall --> Reinstall
        2012 Update 4 x64    :    Uninstall --> Reinstall

    3. Uninstall --> Reinstall Net Framework (not possible)
        3.5                      :    When double clicked will not start. Unsure what the reason is.
        3.5 Full Installer    :    When double clicked will not start. Unsure what the reason is.
        4.5                      :    Microsoft .NET Framework 4.5 is already a part of this operating system.  You do not need to install the .NET Framework 4.5 redistributable.
                                         Same or higher version of .NET Framework 4.5 has already been installed on this computer.
        4.6                      :    Blocking Issues:
                                        The .NET Framework 4.6 redistributable does not apply to this operating system. Please download the .NET Framework 4.6 for your operating system from the <A HREF="http://go.microsoft.com/fwlink/?LinkId=528220">Microsoft Download Center</A>. 

    4. Chkdsk c: /f to completion.
        NB: If a /r is appended the scan freezes at 13% since I am using an SSD.

    5. Uninstall --> Reinstall latest version of DirectX
        No change in behaviour.

    6. Run Windows Memory Diagnostic
        No errors detected.

UPDATED/CONTINUED 01
    7. Run Vuze as an Administrator

    8. Run Vuze in compatibility mode for:
           a. Windows 7
           b. Windows 8.1
Reply
#2
Bump.
Reply
#3
I'm not sure, did not tried yet Win 10, but seems as Vuze itself currently not supporting Win 10, also according with other posts about this problem across a web.

But tried you running Vuze as Administrator plus starting application in compatibility, say, with 8.1 or 7?

I'm myself on the way to Win 10, then I my own will facing with issue.
Reply
#4
@fields

Yes I had tried starting it as Administrator and also in Compatibility mode for both Windows 8.1 and Windows 7 sadly neither of these seemed to fix the problem.

I am not 100% sure about this but I believe it only stopped working in Windows 10 after a few hours so maybe it works in Vanilla Windows 10 but has compatibility issues with other Applications or background System Updates.

The current workaround I came across was to use Vuze for Chrome. This isn't optimal and you lose a whole host of quality of life features but at the end of the day it means I can torrent and I tend to always have Chrome open so it fulfills my needs. Its like stripped down Vuze; not as many features but all the core requirements are met and it seems to bypass the issue I am having with other BitTorrent applications (namely that I believe the ISP is blocking Torrent traffic).
Reply
#5
I know this is off topic but if you think your ISP is shaping your traffic try a glasnost test:

http://broadband.mpi-sws.org/transparency/bttest.php

That should answer the question pretty definitively!
Reply
#6
I have the same problem. I was able to work around the problem by creating a launcher.bat file (simple text file), and putting the following code into it:


Code:
@echo off
cd /D "C:\Program Files\Vuze"
start "Vuze" javaw -classpath Azureus2.jar;swt.jar org.gudy.azureus2.ui.swt.Main %1
exit

This works fairly well for torrent files (I can set torrent files to open with this script), but it doesn't work so well with the magnet url protocol or rather, magnet url links.

I am looking to understand what happens when opening Azureus.exe. I understand it "stubs" the java program, but how?
Reply
#7
(07-01-2016, 01:14 AM)'argo' Wrote: I have the same problem. I was able to work around the problem by creating a launcher.bat file (simple text file), and putting the following code into it:



Code:
@echo off
cd /D "C:\Program Files\Vuze"
start "Vuze" javaw -classpath Azureus2.jar;swt.jar org.gudy.azureus2.ui.swt.Main %1
exit

This works fairly well for torrent files (I can set torrent files to open with this script), but it doesn't work so well with the magnet url protocol or rather, magnet url links.

I am looking to understand what happens when opening Azureus.exe. I understand it "stubs" the java program, but how?

 

Hi

I am getting exactly this error code with Win10 too. I have run all the updates and am fully updated to the latest Win10 version. I am also running DirectX v12.

Nothing fixes this problem!

I tried running your BAT file, but it doesn't appear to do anything. Shouldn't the executable appear in it somewhere? (azureus.exe)?
Reply
#8
SOLVED!

I installed a 32bit version of Vuze (http://www.filehorse.com/download-vuze-32/)
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Change memory limits on macOS without "accept incoming network connections" on start? detelosk 1 10 11 hours ago
Last Post: ArronM
  Vuze shutting down at start up. Ubuntu 16.04. AleXyZ 0 77 12-19-2016, 12:07 PM
Last Post: AleXyZ



Users browsing this thread: 1 Guest(s)